Hey all!

We've just implemented a new version of our old forum ranks!

The new "Idle Villager" rank has some slightly limited abilities here in the forums, and they cannot post discussions or do things like post links or set a signature on their posts. When you have commented 3 times you'll reach the rank of "Scout Cavalry" and gain all the usual posting abilities! This is to help combat spam, and should not affect most of you, as you have likely already posted more than 5 times and have a higher rank:)

Check out the list of ranks here: https://forums.ageofempires.com/discussion/15139/forum-rank-system/p1?new=1

For players who are crashing/unable to launch

CheeseOnToastCheeseOnToast England Member, Developer ✭Knight✭

For anyone still having issues launching or crashing after following the steps on the support page ( https://www.ageofempires.com/support ), we want to hear from you! Please report your issue using the steps found at: https://www.ageofempires.com/support#report

We are working hard to diagnose the underlying issues. Thank you to everyone who has posted additional information and/or workarounds in the meantime!

«13

Comments

  • east puppeteast puppet Member ✭Scout Cavalry✭

    WOW thanks for the prompt response from the dev team LOL you guys really have no clue what your doing do you?

  • CheeseOnToastCheeseOnToast England Member, Developer ✭Knight✭

    @east puppet said:
    WOW thanks for the prompt response from the dev team LOL you guys really have no clue what your doing do you?

    Here's what we know so far:

    1. There is a potential DCOM issue when a user is logged into Windows using a local account or low on disk space which makes the game fail to start.
    2. There is a potential language/region issue for people starting the game for the first time.

    We're investigating both and trying to find a good reproduction case, we're also looking at similar machine setups which are sent to us in support emails to find a pattern. -- To fix these bugs we need to be able to reproduce them.

    Whilst some of the issues being reported are deterring, be sure we're working on finding a solution for everything brought up so everyone can start and play the game.

  • CheeseOnToastCheeseOnToast England Member, Developer ✭Knight✭

    Bumping for visibility.

  • vampiretrixvampiretrix Member, Insider ✭Scout Cavalry✭
    I had the same issue, opening AoE:DE crashed and openened the store.
    Issue seems to be F-Secure, but how do you whitelist a store program - afaik, this is not possible?
  • LegionGenie198LegionGenie198 Member, Insider ✭Idle Villager✭
    My issue is that game crashes after ~5-10 minutes in game. I cant play any game
  • justastupidmanjustastupidman GermanyMember, Insider ✭Ox Cart✭
    edited February 25

    @vampiretrix said:
    I had the same issue, opening AoE:DE crashed and openened the store.

    Issue seems to be F-Secure, but how do you whitelist a store program - afaik, this is not possible?

    I had the same issue with F-Secure and my solution was to deactivate DeepGuard.

  • CheeseOnToastCheeseOnToast England Member, Developer ✭Knight✭

    Bumping again for visibility.

  • DanzemonDanzemon Canberra AustraliaMember, Insider ✭Scout Cavalry✭
    edited February 26

    Sometimes my game decides to not work after a few days of working fine.

    It gives me error 317 in regards to DCOM Server.

    A workaround for this that has worked for me (Took this from Forza 7 forums with the same issue)

    1. Open up Run by pressing Win+R and type services.msc
    2. Once opened, navigate the long list to Windows PushToInstall
    3. Right click and hit properties.
    4. Set start up to Automatic and Start the service.
    5. Now see if the game runs for you! It fixed it for me so It may work for you as well. Don't ask me why it needs that service because I don't know myself.

    @CheeseOnToast My System Specs are:

    Windows 10 Pro Build 16299.248 all currently up to date.
    i7 7700K OC'ed to 5ghz
    32GB DDR4 3000mhz RAM
    C: Samsung 850 evo 120GB (where AOE DE is installed with 55GB free)
    D Drive: 4TB HDD Barracuda (over 2TB free space)
    GPU: NVIDIA Geforce GTX 1080Ti Reference Model with +150mhz OC on the Core and +175mhz OC Memory

    Specific Error Message from Event Viewer: Unable to start a DCOM Server:

    Microsoft.MSDallas_1.3.5101.2_x64__8wekyb3d8bbwe!App as Unavailable/Unavailable. The error:
    "317"
    Happened while starting this command:
    "C:\Program Files\WindowsApps\Microsoft.MSDallas_1.3.5101.2_x64__8wekyb3d8bbwe\AoEDE.exe" -ServerName:App.AppXk5nq8fm9836s7v2wt0ddnryrptdfb1e5.mca

  • ELDYLO64ELDYLO64 Member ✭Idle Villager✭
    My game was working flawlessly yesterday but today when I try to load up a map it directs me to the windows store then shuts the game down. I know for certain that it’s not a hardware problem because it was working before and now it’s not
  • XebiloXebilo Member ✭Idle Villager✭
    > @ELDYLO64 said:
    > My game was working flawlessly yesterday but today when I try to load up a map it directs me to the windows store then shuts the game down. I know for certain that it’s not a hardware problem because it was working before and now it’s not

    Same issue for me. Worked for a couple of days and now stopped working.

    Antivirus and firewall exceptions are made but still issues :/
  • XebiloXebilo Member ✭Idle Villager✭
    > @Xebilo said:
    > > @ELDYLO64 said:
    > > My game was working flawlessly yesterday but today when I try to load up a map it directs me to the windows store then shuts the game down. I know for certain that it’s not a hardware problem because it was working before and now it’s not
    >
    > Same issue for me. Worked for a couple of days and now stopped working.
    >
    > Antivirus and firewall exceptions are made but still issues :/


    Nvm recently installed COMMODO Firewall.

    Even tough i deactivated firewall and disabled everything i could find it was still doing "Do heuristic command-line analyisis for certain applications".

    I also added AoEDE to "Don't detect shellcode injections in these applications"

    Now its working again!
  • Stevenx110Stevenx110 ColombiaMember, Insider ✭Scout Cavalry✭

    Buenas noches

    Fuí uno de los ganadores de su concurso realizado en el mes de noviembre de 2017. Gané el CD Sountrack y un codigo de AoE Definitive Edition. En el mes de enero de 2018 pude acceder a la beta del juego y juegé sin problema. Adjunto imagenes que lo prueban.


    El 20 de febrero me dispuse a jugar AoE Definitive Edition y el juego me apareció lo siguiente:

    Es 27 de febrero (una semana después del lanzamiento) y me he tratado de comunicar por correo al centro de soporte, he revisado los foros oficiales y no oficiales y sigo sin recibir respuesta alguna de parte de ustedes para poder jugar la versión final de AoE Definitive Edition.

    El error es el siguiente, abró la aplicación y se mantiene así por unos segundos. Después se cierra de manera inesperada y aparece el siguente mensaje: "Sabemos que tienes muchas ganas de comenzar, pero deberás esperar un poco más. Ve a la Tienda para consultar la fecha de lanzamiento."

    He realizado los siguientes pasos sin tener un resultado favorable:

    1. Desinstalar el juego y reiniciar la computadora
    2. Volver a re-instalar el juego (Teniendo en cuenta que en mi país una conexión de internet estándar la descarga implica 8-9 horas)
    3. Ejecutar la app Servicios y reiniciar uno de los componentes llamado "PushtoInstall"
    4. Ejecutar el asistente "Windows Store Troubleshooter" para reparar los componentes de la tienda.
    5. Restablecer AoEDe desde el menu configuración y limpiar el cache
    6. Desinstalar el antivirus que dispongo "Kaspersky"
    7. Instalar el paquete de idioma Ingles (Estados Unidos) y colocarlo como idioma predeterminado e instalar las actualizaciones de la Windows Store.

    Espero que me puedan ayudar o lancen algun parche que solucione el error.
    Gracias

  • EkvedojEkvedoj Member, Insider ✭Scout Cavalry✭

    Probaste revisar si el Reloj del sistema tiene bien la fecha, hora y zona horaria? Tal vez tenga que ver con eso.

  • HumHum Member ✭Scout Cavalry✭

    The solution is to launch the game on the Xbox, but for this it is necessary to release the use of keyboard and mouse in the console.

    Another solution, would be to launch in steam, which does not have as many bugs as the Microsoft Store.

    But i still preferred to see the age of empires running on the Xbox. consoles do not have all these types of problems you have on PC, just plug in and play.

  • FRosenqvistFRosenqvist Member ✭Idle Villager✭
    > @CheeseOnToast said:
    > @east puppet said:
    > WOW thanks for the prompt response from the dev team LOL you guys really have no clue what your doing do you?
    >
    >
    >
    >
    >
    > Here's what we know so far:
    >
    >
    > * There is a potential DCOM issue when a user is logged into Windows using a local account or low on disk space which makes the game fail to start.
    > * There is a potential language/region issue for people starting the game for the first time.
    >
    > We're investigating both and trying to find a good reproduction case, we're also looking at similar machine setups which are sent to us in support emails to find a pattern. -- To fix these bugs we need to be able to reproduce them.
    >
    > Whilst some of the issues being reported are deterring, be sure we're working on finding a solution for everything brought up so everyone can start and play the game.

    The part about being able to reproduce the bugs is not always true. Many of your bugs can also probably be found by code reviews. Which I recommend you do as it's pretty obvious you have not been doing during the development.
  • FRosenqvistFRosenqvist Member ✭Idle Villager✭
    IF you don't know what I'm talking about, let your developers sit down and inspect the actual code that runs under startup and look for things that could cause problems. I can guarantee that you will find the startup crash problem this way.
  • Matas sMatisMatas sMatis Member ✭Scout Cavalry✭

    sad and shame that those who play pirated version everything is ok.... i saw on tracker AoEDE game, and people play it after one week after release. I bought legit copy and I cant $$$$ing start it...

  • LordDragantaLordDraganta Member, Insider ✭Scout Cavalry✭

    @FRosenqvist said:
    IF you don't know what I'm talking about, let your developers sit down and inspect the actual code that runs under startup and look for things that could cause problems. I can guarantee that you will find the startup crash problem this way.

    You cannot know this without seeing the code. And you have obviously never worked on a large scale coding project. Projects like these become so big, you can't just read a few rules of code and find the problem. Don't talk about stuff you know nothing about.

  • CheeseOnToastCheeseOnToast England Member, Developer ✭Knight✭
    edited February 28

    @FRosenqvist said:
    > @CheeseOnToast said:

    > @east puppet said:

    > WOW thanks for the prompt response from the dev team LOL you guys really have no clue what your doing do you?

    >

    >

    >

    >

    >

    > Here's what we know so far:

    >

    >

    > * There is a potential DCOM issue when a user is logged into Windows using a local account or low on disk space which makes the game fail to start.

    > * There is a potential language/region issue for people starting the game for the first time.

    >

    > We're investigating both and trying to find a good reproduction case, we're also looking at similar machine setups which are sent to us in support emails to find a pattern. -- To fix these bugs we need to be able to reproduce them.

    >

    > Whilst some of the issues being reported are deterring, be sure we're working on finding a solution for everything brought up so everyone can start and play the game.



    The part about being able to reproduce the bugs is not always true. Many of your bugs can also probably be found by code reviews. Which I recommend you do as it's pretty obvious you have not been doing during the development.

    @FRosenqvist said:
    IF you don't know what I'm talking about, let your developers sit down and inspect the actual code that runs under startup and look for things that could cause problems. I can guarantee that you will find the startup crash problem this way.

    We've had several senior engineers review the code -- Internally there has been some changes to what may be the culprit is but it is not ideal to hack away at the code on such a large scale game like AOE.

    Reproducing and debugging is much safer.

  • FRosenqvistFRosenqvist Member ✭Idle Villager✭
    > @LordDraganta said:
    > @FRosenqvist said:
    > IF you don't know what I'm talking about, let your developers sit down and inspect the actual code that runs under startup and look for things that could cause problems. I can guarantee that you will find the startup crash problem this way.
    >
    >
    >
    >
    >
    > You cannot know this without seeing the code. And you have obviously never worked on a large scale coding project. Projects like these become so big, you can't just read a few rules of code and find the problem. Don't talk about stuff you know nothing about.

    I work on large scale coding projects for a living. And by your wording "few rules of code", I believe it's you who don't know what you are talking about. And besides, I didn't tell them to go over the whole code base now did I? I told them to review the code that executes at startup, which probably isn't as big as you may think.
  • BombayGypsyBombayGypsy Member ✭Idle Villager✭
    Hey guys, I live in India 17GB takes time. About 3 hours. I downloaded it once, it worked, but only for 2 hours! Next morning it refused to launch. I uninstalled and downloaded again. It worked for an evening, and then the next day, it refuses to launch. This is the last time I am downloading it. Release a patch or something to fix this issue, or else I will forget all about it, and the silly Microsoft store. An app which has only been used once by me, that was to download Aoe DE. I will start telling people not to buy DE, and just stay on voobly, coz screw it right, we are after all just throwing our money away.
  • Stevenx110Stevenx110 ColombiaMember, Insider ✭Scout Cavalry✭
    edited February 28

    @Ekvedoj said:
    Probaste revisar si el Reloj del sistema tiene bien la fecha, hora y zona horaria? Tal vez tenga que ver con eso.

    Acabo de hacer la prueba cambiando la fecha, hora y la zona horaria pero nada. Le agradezco su consejo, hubiese sido fantastico que se arreglara así.

  • hazqthazqt Member ✭Idle Villager✭
    can't open the game either, installed it 2 or 3 times today and nothing, tried everything in the support thread and nothing... what a shitshow.
  • flamebreak zflamebreak z Member, Insider ✭Scout Cavalry✭

    @LegionGenie198 said:
    My issue is that game crashes after ~5-10 minutes in game. I cant play any game

    I have the same issue on my desktop, so I just play on my laptop. I found that limiting framerate to 30 from settings restricts the problem, but it's not ideal. Not to mention in MP framerate cap does nothing, so I just can't play MP on my desktop.

  • HumHum Member ✭Scout Cavalry✭

    Developer,
    despite the critics and the initial problems, I would like to register that the game is very good and fun.

    For me, this step solved: "Install any free app from the Microsoft Store" . Unfortunately, I have to do this every time I turn off the PC.

    Im also having some problem with the game crashing in the middle of a match.

    But I keep insisting because the game is great.

    I'm in the crowd to be taken to the Xbox and then we would no longer have these compatibility issues.

    Hugs

  • hazqthazqt Member ✭Idle Villager✭
    "1: Game was installed since pre-order; Crashed after reaching splash screen with logo
    > 2: Reinstalled, reset the game, installed candy crush, restarted Microsoft store services; Crashed after reaching splash screen with logo
    > 3: Did the same thing again; Crashed after reaching splash screen with logo
    > 4: Added English(US) keyboard layout (Swedish is default) in case locale had anything to do with it; Crashed after reaching splash screen with logo
    > 5: Got a prompt from Microsoft store to update settings due to the new keyboard layout; Crashed after reaching splash screen with logo
    > 6: Removed the English(US) keyboard layout, updated the Microsoft store again and reset the game via Settings -> Apps -> Age of Empires: Definite Edition -> advanced options -> reset; Was finally able to launch and play the game without problems"

    This fixed the launch problem for me. Give it a try.
  • POOSPOOS Member, Insider ✭Scout Cavalry✭

    @Danzemon said:
    Sometimes my game decides to not work after a few days of working fine.

    It gives me error 317 in regards to DCOM Server.

    A workaround for this that has worked for me (Took this from Forza 7 forums with the same issue)

    1. Open up Run by pressing Win+R and type services.msc
    2. Once opened, navigate the long list to Windows PushToInstall
    3. Right click and hit properties.
    4. Set start up to Automatic and Start the service.
    5. Now see if the game runs for you! It fixed it for me so It may work for you as well. Don't ask me why it needs that service because I don't know myself.

    I tried all of the other potential fixes but nope.
    This actually made my game start. Thank you!

  • Matas sMatisMatas sMatis Member ✭Scout Cavalry✭

    didnt help at all. When I start service Windows PushToInstall and refresh window, service is not running again. WHen I set trigger to automatic start its just says that its triggered, but not running....

  • scotFNharvathscotFNharvath Member ✭Scout Cavalry✭
    edited March 2

    i tried the rest suggestion per @hazqt and the service suggestion per @Danzemon... no dice. I've also tried uninstalling and reinstalling from the Windows Store.

    An i tried running the troubleshooter... https://support.microsoft.com/en-us/help/4027498/windows-10-run-the-troubleshooter-for-apps

  • Matas sMatisMatas sMatis Member ✭Scout Cavalry✭

    if you reset store cache, after relaunching this app you will get the same error.... this thing really XXisses me off....Microsoft c'mon.... two weeks..... still cant run the game...

«13
Sign In or Register to comment.