Hey all, since the beta is over now we have closed down the beta specific forums. Don't freak out if you can't see it, it's not a glitch:)

Cheers,
jennywaboom
Hey all!

We've just implemented a new version of our old forum ranks!

The new "Idle Villager" rank has some slightly limited abilities here in the forums, and they cannot post discussions or do things like post links or set a signature on their posts. When you have commented 3 times you'll reach the rank of "Scout Cavalry" and gain all the usual posting abilities! This is to help combat spam, and should not affect most of you, as you have likely already posted more than 5 times and have a higher rank:)

Check out the list of ranks here: https://forums.ageofempires.com/discussion/15139/forum-rank-system/p1?new=1

I can't get the game to load??

SaBsTeR55SaBsTeR55 Member ✭Idle Villager✭

I received a copy of AoE 2 on steam and installed it. But the game wont actually load. I hit play on steam, then hit play on the AoE menu. it changes to a validating subscriptions page then vanishes and the game just doesn't play.....

Answers

  • PhatFish AoEHPhatFish AoEH CheeselandMember, Insider ✭Ox Cart✭

    Having the same problem for a couple of months now.

  • TNC PinEapPleTNC PinEapPle Member, Insider ✭Scout Cavalry✭

    Try validating the flies cache first. Will probably not fix anything since you have this problem straight after downloading the game but always get this out of the way first.

  • nomad519nomad519 Member, Insider ✭Idle Villager✭

    Try validating game cache. Also try spamming the spacebar when you're at the validating subscriptions page, it works for me. Make sure you don't have any workshop content installed that might interfere wight other workshop content or the game itself. What OS are you on?

Sign In or Register to comment.