3D water rendering bug

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 7486483
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Coastal water appears bugged when playing any game where shallow water is present in coastlines, as shown in the image below. Sometimes it starts happening only after the second game I play and onwards after launching the game. Sometimes right in the first one. Sometimes I generate maps in the editor and looks fine but when I test the map the bug appears. Sometimes it happens in the editor view with no need to test the map. I couldn’t find a pattern yet.
It began when hanging around in the editor. After I generated a random map in a greenlad seed the bug appeared and never left. I tried disabling all mods, deleting games files related to textures and verifying files integrity afterwards with the steam tool, and even tried reinstalling the whole game. Nothing worked. The only “solution” is to turn off 3d water in the graphic settings.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS after the first game. Sometimes right in the first game)

:arrow_forward: REPRODUCTION STEPS

Launch a game. Maybe two.

:arrow_forward: IMAGE

Notice the squares around the water

My graphic settings:

(yes that’s an UI mod there, but as I said I’ve already tried disabling all mods)

Edit: Just in case, I want to make clear that this happens in every kind of game. RM, multiplayer, campaigns and the scenario editor

Hey @Gaudio3342
thanks for the report, we are currently tracking the issue.
have a nice day :slight_smile:

1 Like