African Royals Challenges not progressing

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • **GAME BUILD #:100.12.43871.0
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

The third day 9 challenge, build 3 watch towers as the Ethiopians or Hausa in a game, is not progressing. The progress UI element will show up in-game and track as I build watch towers, but when I quit the game the icon for the challenge shows a clock icon. I first tried this two days ago (Monday night EST), waited until yesterday and experienced the same issue
(Tuesday night EST), and am seeing the same thing today (Wednesday night EST). The challenges after it are locked.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Click on the “African Royals” event challenges button on the main menu
  2. Scroll to the right to see the Day 9 Challenges

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
I’d be able to continue to further challenges

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe3Ysav) or GAME RECORDING (.aoe3Yrec) of the match where you encountered the issue. Link it below if using an external file service.

You sure you are building ‘watch towers’ of ethiopians age 1 or are they sentry towers etc… (upgraded towers)?

Also, don’t quit the game, resign.

Okay, I don’t know which of these things was the one that made it work, but I tried again from the Exploration Age building unupgraded watch towers (the UI had been tracking it as I built upgraded ones, though) and resigned when I was finished, and the challenge progressed.

Thank you!

1 Like