After the intro the game crashes and I land on the desktop again

Hi there,

I bought Age of Empires 2 Definitive Edition for Windows Store today.
After the intro the game crashes and I land on the desktop again.
I have already uninstalled and reinstalled the game.
What can I do?

OS: Win 10 Home 64 bit (all updates / patches installed)
CPU: Ryzen 5
GPU: Radeon 560X (latest driver installed)

Best wishes

Today the game worked one time. After closing and restarting it crashes after the splash screen.

Best Regards

No improvement with hotfix 35209 from 13.02.2020. Unfortunately does not start yet.

Note: I have an Asus FX705DY notebook with Ryzen 5 + Vega 8 + Radeon 560X graphics.

There are some solutions here
I suggest trying to manually update Microsoft Visual C++ Redistributables and see if that helps.


thank you for your answer.
I updated Microsoft Visual C++ Redistributables, restarted and it again doesn’t work.
Perhaps it is a problem with the AMD-Hardware?

Might be that the laptop is using the integrated Vega 8 graphics card, but not sure to be honest. There is a guide here on how to make sure the game uses RX560:
Additionally, check if the system page file size is set to system managed and that your antivirus isn’t blocking the game. Good luck.

P.S. did you install any mods in game, the one time you managed to run it?

1 Like

I have set the graphics setting to ‘high performance’, unfortunately this did not help.
System page file size is system managed.
I have Bitdefender Internet Security 2020. I deactivated it, but the game also doesn’t start.
I tried to add AoE2DE.exe to the exceptions. However, I have the Microsoft Store version. I can’t get into the MicrosoftApps folder with Bitdefender and therefore cannot add AoE2DE.exe to the exceptions.

I have installed the Enhanced Graphics Pack.

I have now uninstalled the game and reinstalled it without the Enhanced Graphics Pack.
Now it worked 3 times in a row.

Thanks for your help!