Age Of Empires 2 HD "Failed Drawn System"

I’m traying to play this game, but when I click in Play this message appear:

“Failed to initialize draw system: c:/users/jakes_workstation/documents/projects/age_of_empires_2_de/phoenix/age2hd_archieve_5.7_with_hotfix/aoc/source/main.cpp(312).”

I tryed everything, change the name of the “Exe” AOK to Launcher, runned the diagnostic of integrati the game, everything…

The error is the same!
I hope someone will help me to solve this…

Conf computer

W 10

4 GB Ram

Processador Intel Core 2 Quad

Sistema 64 bits

Microsoft Visual C++ 15

DirectX 12

When i click on Play the message above appear…

On steam:

I found a app named “Duet Display” , it can use your iPad connect to your PC and become a second monitor, but the app will conflict with steam AOE HD, only way is uninstall it.

Sorry buddy, i don’t understand what you said.
Can you be more specific? With some steps to follow?
If you need more information, you can ask!

Someone on Steam had the main.cpp(312) problem also and solved it by removing the app named “duet display”. This worked for others too.

But the most likely problem and solution is here:

– seems outdated internal graphics cards is the problem –

I’m quite confused by the

If you’re in the AoE 2 DE Beta I would probably also post this in the closed beta forum.

thank you buddy for shared this, i’ll check. im trying to solve this… thanks!