Age of Empires: Definitive Edition - Content Update 3 - Age of Empires


#21

Well, before this update, the game doesn’t launch and sometimes sends me the message: “You require internet connection”.
Now, with this update, i have two new troubles.

  1. The Game doesn’t detect DirectX 11… but, all of my drivers are up to date (I’m reinstalling GeForce Experience right now to solve this, i hope that works with this.)
  2. FontFile_Failure…

But, i had moved the game to other unit and finally, after so much days without play, i cant play… You need to test why the game doesnt launch.


#22

what are you doing to AI ??? the AI is horrible… i cant play against the pc !!


#23

my client is still on 5101 and I cant figure out how to update to the new version… Any suggestions?


#24

hello i have downloadet age of empire definitive ED v 5147 and its still in beta (feels like it) I can not play it ,it crashes to Microsoft store every time i try to start it after the main menu …no matter if you chose single or multiplayer …this is not a good programming its surpose to be written to win 10 …and yes i have tried every thing that was written on the forum…(just pore programming) …and its a shame becurse its a good game.


#25

Still doesn’t work. Crashes when trying to start the game… as before.


#26

-pre 5147 worked fine… -after 5147 start campaign… --> crash to windows store


#27

working fine before this 5147. now not possible to play. crash to windows directly !


#28

was working fine until today. Now I open a random map match vs ai and it crashed after a few seconds in game


#29

Rankin system will be really nice


#30

Hello there! I just downloaded the game - congrats, its really good, a lot of memories awakened - For me the bugs are funny, not annoying. Like we don’t have marketplace yet… :stuck_out_tongue: Thanks a lot for this remarkable job. :slight_smile:


#31

Game doesn’t work on windows enterprise editions, or any custom version with no windows store/xbox live, even if you manually download the files and try to run it. It simply will not work on those versions. Works smoothly on my win10 home edition on both i7 2600k +gtx580sli and my phenom x4 955 +gtx760sc . Never had an issue on the home edition.

Devs if you reading this, please add mod support, the community thrive on it and will provide their own game tweaks. It will actually make or break this game. Please let AOE4 have proper mod support too. Think about all the most successful RTS and they all have mod support and custom map creation tools, Look at the likes of Warcraft 3 and age of empires 2? What makes those games so popular? Mod support and custom created content, as well as a platform that is user friendly and intuitive.

Please make sure aoe4 is perfect before you release it! You have a cult like following on this game it’s gotta be perfect!


#32

@cdreed3000 said:
My game worked fine at first, but after a few days started freezing for a bit and then crashing every time I got about a minute into a game even after reinstalling. This update fixed my issue and now it works beautifully again! Thanks!

I spoke too soon. My game is back to freezing and crashing after being open for a few minutes. So frustrating!

I did notice something new though. I thought it was just crashing when I start new games, but I spent too long deciding on who I wanted to play as and it froze and crashed the same way before I started the custom match.


#33

You’re doing a great job! I only miss a ranking system and we are home. Any idea of when a ranking system, ELO or something else, is going to be implemented?


#34

After some testing:

Saved games actually work!

It’s starting a new game (single player - custom game or campaign) that sends me to the windows store…


#35

@SunwardBooch720 said:
After some testing:

Saved games actually work!

It’s starting a new game (single player - custom game or campaign) that sends me to the windows store…

OK, got everything working again:

After a patch (like 5147) the antivirus exception/whitelisting is pointing to the old .exe ( so this rule is no longer valid)

steps
1 remove the old rule from your AV
2 assign the exception in your AV to the .exe again

path: C:\Program Files\WindowsApps\Microsoft.MSDallas_1.3.5147.2_x64__8wekyb3d8bbwe\AoEDE.exe

Everything works again ( well, for me …)

------from the support page:

Check your antivirus settings.
Some antivirus programs may prevent the game from launching. Check your antivirus settings to make sure Age of Empires: Definitive Edition is not being blocked.
Add the game to any whitelist feature in your antivirus program.
Here are a few particular antivirus programs with known conflicts, and resolution steps for each:
Avast: Age of Empires DE must be added to the program’s whitelist.
Comodo: disable shellcode injection detection.
F-secure: Age of Empires DE must be added to the program’s whitelist.
Trend Micro: follow the steps listed here.


#36

These basic issues should have been fixed during beta testing and extended release deadline. Also… there was no effort to actually improve gameplay mechanics and barely any noticeable addition to unit variation. The game merely has enhanced graphics. AoE DE is a huge disappointment.


#37

this update doesnt mean anything to me. problems i see and care, are about pathfinding, balance and A.I… and apperantly you didnt adressed them at all. i am jumping on the “dissapointed” side. your wasting all these potential a new AOE can achieve, dont expect any success with this crippled pathfinding, A.I. and unit/civ balance… And dont dare to blame AOE for that, its your own fault that you do nothing to update gameplay to 2018.


#38

add more civilization please !!


#39

When I build a Wall around my city, there is no option to build a GATE??? does anyone know how to build a gate?


#40

Game still doesn’t launch for me