📜 Age of Empires II: Definitive Edition — Update 37650

Are you guys logging in through an xbox live account? If so, I had a similar issue. I fixed it by using Window’s Task Manager to end the xbox tasks, then restarted the computer and it worked.

fixed the connection problem with the new package. now the problem of low fps has begun.

Congrats for the poor job


I lose connection ALL the time now… i can’t play ranked. always get disconnect before the game start and when it start AoE2 crash at loading screen… wtf.


I just pressed ok and continued

There seems to be a problem with Team Games. People have issues connecting.

1 Like

Do u think we are stupid? It crashes anyways

1 Like

Here’s a thread on the issue about AoEURLInstaller_Steam.exe/VCRUNTIME140_1.dll:

not for me lmao :joy:

I got the VCRUNTIME140_1.dll error, so I had to install VC runtime. Now I am unable to join any ranked games. The match making finds a game then it gets to 0 countdown timer, then says failed to join game. Unranked seems to work OK. This is very annoying. :expressionless:

I had the same error. Just press ok abd the game launches normally

I’m talking in general looking at posted dxdiag reports. And also that build should still be supported in the extended time (that is until next new build coming end September / begin October).

Also you have withdrawn your posts already. But your issue might be related to something else, so then I would suggest to create a dedicated bug report about this issue.

1 Like

Then you should post a dedicated bug report like I said already.

1 Like

You can correct the error by manually installing the following program. =)


From yesterday after update I can´t play between Steam and MS Store players, just two days ago I hadn´t that problem. Something happen that Steam users can´t play with Ms Store users. Someone knows what happen? There is any fix for it?

I have had the same error

Can you guys stop sending me fixes please? It’s had no effect on my game so I won’t do anything because I can’t be bothered :slight_smile:

still the same bug… what are you doing? the game is unplayable online atm. revert the change and fix it!

The good news is filter is not censoring what I write. The bad news is I can’t write in chat

hay un error que cuando carga la partida en competitivo, a uno le falla cuando entra en la partida.
(con coneccion estable)