📜 Age of Empires II: Definitive Edition — Update 37650

Congrats for the poor job.


I cant even get browse mod to work now. what the heck is this update? reverse all of it and please do not wait 1 month to put another fix to break more things.

give us the old patch back right now and so at least we can play and have no issue with modding.

The same. cant play multiplayer ranked game. The over games are OK.

AI still needs improvement, big time. Got defeated by the HD Barbarian AI in 6 out of 7 games that I have tried so far. Better luck at the next patch :sweat_smile: :grin:

1 Like

Hello everyone! As a quick update, we are tracking several issues with fixes in the works, including the inability to connect to Team Games, the Visual C++ installation error, and others. You can keep track of those issues here:

I will also update everyone as we come up with an action plan to implement fixes, so stay tuned for more and thank you for your patience!


Is the limited FPS intended or a bug? It would be better to have the option to deactivate the limit. Since the new patch the game feels laggy but I used to have like 120 fps on high settings before the patch…

No reply on this? How do I solve the multiplayer connection issue?

I am sure that its not a firewall issue as steam chat, and other games are working fine with no issue. Even AoE2:DE was working fine until this patch was installed.

Please help me!

I tried to check in the logs under games/aoe2:de folder but cant find any error.

If there is no solution, at least let me know if there is a way to revert to previous patch and get rid of this patch.

I keep getting time out or disconnected when trying to start a game

Can you please add ‘Hacking is a real issue and we try to fix this’ to this list. I can’t found this issue at the list.

Another important question here that is usually forgotten

Why does the Cavalry unit Mameluke still have the Archer armor class?
If it is not a slight, or an AoK relic, and is intentional, then I ask is there no better way of balancing them?

Anyone had luck completing last challenge?
I’ve used sheep to find other animals but can’t get it done?

A unit from AOE3 era.

Stop this Parthnan, please.

Please, don’t forget these bugs/issues in the next game update!

Hello developers,

i want to report the following issue. We are a group of four players. Two of use have decent gaming laptops (nvidia gtx 1050/mx230), the other two have low-end laptops with i5 (6.gen) and just the intel hd graphics card. Up to the last update the definitive edition was barely running (20-30 fps) on the low-end pcs and the gaming laptops were running 80+ fps. Since the new update the game is barely running on the gaming pcs 30-40 fps with high fluctuating fps, while the low end pcs performance increased (40-50 fps). That really sucks for the guys with the gaming pc!

Hello everyone! The team has a fix for a handful of serious issues ready to ship in a hotfix build. This includes a fix for the Team Ranked issues, the VCRuntime error, and other important fixes we could get into the build.

We are targeting the earliest window of opportunity to ship the build, which is later today. Once it is available, please ensure you take the time to download the update and let us know if you continue to experience issues.

Thank you for your patience; watch for the update (and more information) later today!


== UPDATE ==

:point_right: Hotfix 37906 is now available!