Age of Empires III - cannot install

Hi,
I have just purchased Age of Empires III on Steam.
When I try to play it for the first time it asks me to copy the CD key to clipboard but when it continues it says it has to install a greyed out Windows feature. I cannot get any further after that.

Any ideas appreciated

I am running a Win 10 PC with 8GB RAM

Thanks

  1. Click on the Search icon in your taskbar, and type in Control Panel .

  2. Click on the top result to launch the classic Control Panel application. As opposed to using the new Settings, you have access to turning Windows Features on or off here.

  3. Change your view mode to Large icons . This enables you to see all Control Panel elements at once.

  4. Find and click on Programs and Features .

  5. Look to the left side of the window and click on the Turn Windows features on or off-link .

  6. If prompted, enter the local account details needed to open this link. This is usually the administrator account password.

  7. Expand Legacy Components by clicking on the plus icon, then place a checkmark in the box next to DirectPlay .

  8. Click OK .

1 Like

Hi, thank you very much for the reply.
I have tried this and for some reason the Turn Windows Off feature is blank.
I have searched online for that and it is to do with my credentials. I don’t understand as I have admin rights.
I tried to run a Powershell script from a Microsoft forum to apply the changes but it says I need to elevate my credentials. I will have to keep trying

Thank you

You should be able to click the box 2 times, so it shjould go blank, and then a tick.
After doing so, it should apply the changes, then you´d need to restart your computer o: