Age of Empires III Installs, But Won't Launch

Hi, I bought a CD copy of Age of Empires III (not a steam key) and am having trouble launching the game. Everything goes smoothly during installation, but when I try to launch the game, I get the ‘loading’ blue circle mouse cursor for a few seconds and then nothing happens. If I open Task Manager at this point, I can see that there is indeed a background process titled ‘Age of Empires 3 (32-bit)’. I have another computer (also windows 10) with the game installed and it runs the game with no problems. I copied the entire game from this computer to the other computer, and it works with no problems (this doesn’t solve my problem because that install is from my other copy of the game (also CD’s) and I’m trying to make a new ESO account so I can play with my brother online). I compared the install files of the two computers and noticed that Age3Launcher.exe is missing from the one that will not run the game. If I uninstall then reinstall the game on the computer that runs the game just fine, I get the same problem as the first computer (game installs but will not run). This has led me to suspect that I am doing something wrong during installation.

I am running Windows 10 home edition (64-bit)

Here is what I have tried so far with identical results:

  • Reinstalling
  • Reinstalling using a different CD set
  • Running the age3.exe in Vista compatibility mode
  • Running the installer in Vista compatibility mode
  • Copying Age3Launcher.exe to the install location and running that (also tried this in Vista compatibility mode)
  • Saying ‘pretty please’

If you need any more information, or if something wasn’t clear, please let me know. Thanks!

Could you check if DirectPlay is enabled on the computer where it doesn’t work.

It is enabled just like your screenshot.

Do the expansions have the same problem?

Did you install msxml (without it the game won’t run):

See here: https://support.microsoft.com/en-za/help/810209/microsoft-games-msxml-error-message

I do not own the expansions.

I installed msxml, but still no luck.

I’m not sure if it also requires .Net 3.5, I think it does need it, but you could check it on other pc.

Did you restart your PC after the msxml install? Restarting is needed for it to work.

BTW are you running the latest patch for this game? something like :
Age of Empires III - game update v.1.14

I did restart after installing msxml. And no, I am not running the latest version. I think the discs have v.1.0. I don’t think it’s possible to update before installing.

1 Install from disk, 2 restart, 3 install latest patch

http://www.agecommunity.com/gameupdates.aspx

1 Like

SOLUTION: I solved the problem by successfully installing the game on an old tower I had lying around. Then I used it to create a new account and signed into that account on the problem computer running the working install. Less than elegant, but it worked. Thanks for all the help guys!

3 Likes