AGE3 Editor Crash opening multiple windows

Game Version:

  • Build: 36906
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: SirSgtCire


I am currently developing a data and lang mod for AoE2 DE, you can look at that here:

I am running into an issue (and have for quite some time now) where I am not able to open up multiple editing windows using the included modding tool. Steps to reproduce are outlined below.

Could we get some improvements to the modding tool, to fix this crash and potentially make modding using this tool easier for us users? It would be great to be able to diff in one window, and be able to in-line edit these kinds of data changes (to units, techs, effects, etc), and avoid this crash all-together.

Hopefully this gets some attention, thank you!

Reproduction Steps:

Here are the steps to reproduce the crash I keep coming across:

Step 1: Open the modding tool found at:
C:\Program Files (x86)\Steam\steamapps\common\AoE2DE\Tools_Builds\AdvancedGenieEditor3.exe

Step 2: Load an instance of the modding tool, using any params for data, lang and drs files

Step 3: Once loaded, use the +++ button at the top left to create another window (supposed to be able to look at multiple data files at once)

Step 4: Repeat step 2, using any params again

Step 5: the modding tool is supposed to load the other instance, but this is where the entire program crashes, and all modding tool windows close


I for some reason am not allowed to add any video content to this post??? only .gif is the closest thing to a video, otherwise I have to take screenshots of the entire process. I also tried zipping the video, but only .jpg, .jpeg, .gif and others are allowed (no video or zip formats)…

Specifically, I can’t upload videos because of:

Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif, txt).

EDIT: I was able to make a gif of JUST the crash, but not the whole process (too long). I hope the steps to reproduce are clear enough, if not let me know!!


1 Like

Opening multiple windows works fine for me.

Looking at your gif, it seems you are not opening using the correct Genie version in your 2nd window. Please be aware that open dialog settings are saved individually for each window you create. The genie version needs to be “Age of Empires II: Definitive Edition”.

UGH, nice find, I couldn’t see that every time I tried, thank you!