AI doesn't work, totally broken

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.101.45340.0 0
  • GAME PLATFORM: Microsoft Store
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


When I start a casual game in singleplayer, it appears this message before the game starts. Then, the AI in game is totally broken, it does nothing. I can go to the Imperial Age while AI is still at first age with only the city center.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!
1)Go to single player or just partecipate to the event Comp-Stomp;
2)Open a new skirmish;
3)Start the game;
4)See that the AI is broken and does nothing.
Here’s the steps to reproduce the issue:

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

A skirmish in which the AI works depending on the difficulty chosen.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

(The message which appears when you start the game)

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

1 Like

Same problem here. The event counts any AI for its challenges but going back to the HD one isn’t the same. Validating Steam files also didn’t fix.

Okay actually, I fixed my game so far. Disabled all my mods and ticked back on one or two at a time. Not sure which one was the culprit though.

Disabling mods worked. Thanks!

I’ve had this exact issue since LotW was released and it impacts all AI difficulties when playing in “skirmish” mode. It’s impacting campaigns as well from LotW, often the second scenarios for some reason. Exact same error as in your screenshot. I’ve disabled all mods, closed and restarted the game and have run a game file integrity check on my steam version with no fix.

The only thing I can think of is that I have created custom .ai and .per files in the past for the HD version of the game back in 2017. Perhaps one of my old files is conflicting and isn’t getting picked up in the update validation? It’s odd it is only showing up now with the update however. I also checked the init.per file in my local directory and it was last updated on the February 18th 2021 so it should be up to date.

Edit: running Windows 10 / Steam / Build 101.101.45340.0 6228353

I had the same problem, I believe it’s the forgotten HD campaign mod that was the culprit.

1 Like

Exact same problem for me. I’ve already tried removing all mods.