AI Script Error since the Lords of the West DLC

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 101.101.44834.0 6148570
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Since the new Lords of the West DLC, I get this error whenever I start any game:
AI Script Error
File: Promisory\init.per2
Line 180: ERR2005:Invalid identifier:
ERR2004: Missing identifier: tc

The AI basically does nothing in any such game. And I also get an error looking at recorded multiplayer games.

I have tried:

  • reinstalling the game
  • unsubscribing from all mods
  • deleting all local files and reinstalling
  • deleting all game files and reinstalling
  • deleting specifically this file and reinstalling

All have had no effect. Any ideas what to do?

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)
    ALWAYS for matches against the AI

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. I start any game against the AI

:arrow_forward: EXPECTED RESULT

No error message, AI players build things

:arrow_forward: IMAGE

:arrow_forward: GAME FILES (SAVE / RECORDING)

SP Replay v101.101.44834.0 @2021.02.04 205202.aoe2record (624.3 KB)

I’m having the exact same issue. I have tried verifying the local cache and even reinstalling but just like you nothing fixed it.

I guess ill be missing out on the 2021 celebration stuff, as I do not want to play games against a dead AI.

1 Like

Usually this error message is caused by a mod affecting the AI (for instance a custom AI). Deleting your mods that affect the AI should solve the issue.

Im wondering - does this happen with the other AIs? (cd version and hd one).
Also, does it happen if you download a custom AI such as the barbarian port?

I’m not using any mods.

No, it only happens with the standard DE AI. If I choose any other AI, no problem

It is indeed an issue with a mod.

One campaign mod contains a bugged AI script. Disabling it will fix your issue.

I have never downloaded any such mod. I have disabled every mod that I do have.

I would recommend unsubscribing from these mods, specially the AI and custom scenario ones, verifying game cache afterwards and checking if it works then.

Thanks for your help. I have:

  • unsubscribed from all mods
  • verified game cache files
  • reinstalled the game just to make sure

Result: identical error