All Civs locked X/S

It’s telling me when I open any game type that I do not own the game but I have it on game pass all the Civs are gone but I can do random pick and it only picks 4 of them and solutions ? I’m on Xbox


I just logged in tonight I’m having the same issue.

Maybe this outage has to do with it not working:

Same problem over here on XSX. Tried logging out of my account and logging back in, tried an Xbox restart as well, but got nothing. Xbox Live issue seems to have cleared up, so I’m not sure what’s going on.

Playing on Xbox 1 with full deluxe edition and all add ons purchased. Only 5 civs available to choose. All other civs are locked and require additional purchase which I’ve already paid for. Playing with friends who are experiencing same issue but playing with game pass. Please resolve!!!

Same issue. But ALL of my Civs appear to be locked even though I literally own all content currently available.

Playing on Xbox series S also with deluxe definite edition all DLCs and preordered the new one today too but can only play as three civs? Was playing just fine this morning.

Yeah I re install and same issue still idk what it could be

I am having this issue too. I have uninstalled and reinstalled, I have tried on a second Xbox, tried accessing the game from another user

Everything is locked. I was playing on game pass but had bought an add on, so I tried buying the base game to see if it would correct the issue and that didn’t work either.

Yeah I don’t care about Game Pass, so I buy all of my games outright.

So as someone who has purchased everything, I can confirm this game is all screwed up. Can’t figure out what the issue is. I have also completely uninstalled and reinstalled the game. Still happening.

I saw someone else mention they played this morning and it was fine…

I’m happy to own the game but I was pretty peeved it didn’t fix the problem

Looks like you can still find a match with whoever you selected last but won’t let you switch

That’s because it did work fine this morning. I played it way earlier and it was fine. This didn’t start happening until a few hours ago.

All my campaign content is locked if I try to start any but it will let me load the campaign I had previously been working on.

Moved to the aoe2 forums.

1 Like

It’s fixed this morning for me.

1 Like

It is fixed for me, too. But for whatever reason it’s still messed up for other people.

1 Like