All content of African Royals DLC is locked, but I bought and installed it

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

I’m not allowed to play African Royals DLC, but I bought and installed it.

  • GAME BUILD #: 100.12.43871.0
  • GAME PLATFORM: Microsoft Store
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


I own the African Royal DLC, because I bought it on Microsoft store, I can download and install it. But all content of this African DLC is locked and unplayable in game.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Install entirely Age of Empires III Definitive edition and African Royals DLC.
  2. Launch the game Age of Empires III Definitive edition.
  3. Access to a skirmish game.
  4. Try to choose an African civilization… you don’t, it’s locked.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

I m allowed access to African Royals DLC and play all its content.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe3Ysav) or GAME RECORDING (.aoe3Yrec) of the match where you encountered the issue. Link it below if using an external file service.


I am having same exact issue also
I have purchased all on the windowsApp
Xbox store

Age of Empires III: Definitive Edition - United States Civilization
Quantity 1

Age of Empires III: DE The African Royals
Quantity 1

Had tried uninstalling the game, I tried resetting the data and game
I tried other options mentioned on

and still the dlc will not unlock

1 Like

Same issue here. deExtremely disappointing

1 Like

You guys are all using Microsoft’s store, correct? Because I’ve seen several people having the same problem and they all are using Microsoft store. There seams to be some issue with the Microsoft store that does not unlock the dlcs even when you own them .



even though installed them both DLC’s and even tried to under the windows store app also tried install the dlcs there are uninstalling them

I even also uninstalled game and DLC’s spent over 10 hours redownloading and installing the game which from around 11:48pm PST to about 10:36 am today it finished installing

to find out all that effort was wasted

sending a support ticket last night was useless to

Microsoft Support for Xbox

they refused to help

purchasing a DLC or two DLC’s within 24 hours

and not being able access them, then sending a support ticket for the two DLC’s
asking for a Refund after trying multiple options that were offered about how fix it from a link they offerd

when tried and tried and tried and couldn’t access the DLC’s I asked for a refund

and they refused and claimed I was able to play the content
even though the content shows a Locked symbol and that when trying to access the united states or the royal african DLC’s

and they showed greyed out options

WindowsApp store

they should be able see all them commentors on the store page for both DLC’s have negitive post about not being able to access the DLC’s

it seems that instead the support staff are ignoring it.

and even refusing to refund broken content broken DLC’s we paid for but can’t play

Neither was I able to Access either DLC’s or play them in skirmish
Neither was I able to use these DLC’s

but for some reason Windows Store App and Or Xbox Support staff didn’t bother to investage my ticket or investigate and help me, instead pretty much autoresponded with a comment or stright out refusal to refund my 2 last purchases

it took me a couple days to download and install the games took long time to download like 62gb’s on a low speed isp

Seems that Microsoft doesn’t care that the DLC’s dont work or are bugged and that we can’t access or play them

1 Like

Microsoft support ticket for refund was denied
(denied because they claimed I was able to play the united states Civilization and or Royal African Civilization)
Even though Proof is I am unable to play them that both content are blocked with a lock symbol ingame

and that the option to play them was grayed out

Instead of Microsoft saying it was a bug or some issue

instead of bothering to investigate my issue or refund my purchase they lied to me and said that I was able and did play the two dlcs that I purchased

I would be really happy if they investigated my issue instead they trolled me

1 Like

Yeah not sure what the issue is. I use steam so that’s where all my aoe games and content is downloaded and haven’t had this problem yet. Sounds like Microsoft store is terrible, which is why I don’t use it. If their support won’t help I don’t really know what to do

1 Like

Wow, that stinks, so basically that don’t care. That’s some great customer service right there.

1 Like

if you checked out the ratings under the game DLC

you see that there is more negitive rating of 1 stars of 60%
compared to 40% of 5 stars

of players more then 5 recently posting that DLC is broken
Yet seems they don’t care or not aware of it, and when its reported they pretend you didn’t post all the information and evidence for them investigate

looks like for few months Microsoft Xbox app store had people posting reviews with broken DLC

Hi guys,

I’m sorry for what happened to you. We are already tracking this issue.


Do you have an stimated time for posting a solution?

1 Like

thank you IkoKnight8151

Glad to read your answer.

1 Like

The next update preview for oct 15th 2021 doesnt say anything about fixing the issue where if u bought both or 1 of the dlcs and u download them and launch the game its still locked. I got them to home city level 8 on all 3 new civs. Im logged into my microsoft account and i uninstalled and reinstalled the game and both dlcs both its still locked. I click on buy now inside th3 game and it says i already own both dlcs. When i play skirmish i can choose all 3 civs for the AI but i cant choose them or got to there home cities. And the list of issues on here dont mention this issue at all. I can access both bought dlcs in age of empires 2 DE but i cant access the dlcs on age of empires 3 DE. So its not me thats the problem or me not signed into my account, its something on microsofts end.

1 Like

Everything was working fine. Purchased and installed over a month ago. Today I find both new civis locked, New DLCs available. Not sure what’s changed in the last 24 hours?

1 Like

He tenido el mismo problema con microsoft store, incluso traté de reinstalar el juego completo y nada funcionó, mis amigos de steam no tienen este mismo problema.

1 Like

Same here. Bought when both was first available. Everything was fine and unlocked and leveled my 3 home cities. Yesterday i got on and all 3 dlcs locked.

1 Like

same here yesterday did play and finish day 11 African royals challenges but today can’t complete day 12 because can’t select African nation
hope they fix it soon 5 days left to complete


Dlc are available now and playable. Issue has gone. Well done developer team !

Same issue here, installed, desinstalled and still nothing

1 Like