Anniversary Event - Issue with completing Challenges

at this point i just gave up trying to understand how anything works
it suddenly decided to detect i actually did it already

still, people that got the games on different platforms should still get this reward, it’s rly unfair to not reward people just because their games are on different platforms, they still supported the games and cared to get the achievement

1 Like

Also not working for me, AOE2DE on Steam, aoe msstore.

This should be fixed asap, I feel like Microsoft giving me the finger for actually being so idiotic to use their store. It’s like Idiot - why you not use Steam?

Before that I spend 4 hours to Install AoeDe again. I hadn’t played in a year and with the 2800 update you had to completly download the game again.

But I tried doing that I go the error non of your devices supports this game. Took me almost an hour finding a post saying you need Windows 10 Version 9003. Like Microsoft can’t add a proper Error Message for that… Like Microsoft never adds proper Error Messages.

Hadn’t the Version since my Windows 10 Enterpise does not Automatically update the Windows Version

After 2 hours Updating Windows (Not Ecceragated) I finally could install AoeDe and after the achievement. But to figure out I had the achievement I first had to download the Xbox beta app which also nobody told you

And it still did not Work…

1 Like

Your games are both on steam right?You mean the challenge suddenly completed by itself and you just don’t know why?Hope I would be as lucky as you :rofl:

1 Like

Well I did do the achievement, but it didn’t want to register until that last reply.
Rly can’t tell wtf the game’s trying to look at.
All i can tell is that I at least opened AoE DE once or twice be4 it randomly decided that “oh yeah you actually did it”

shrug PR

Probably the only solution I can give is to buy it on Steam, quickly do that one achievement then request a refund.

I still don’t understand why the first achievement is sign in with Xbox Live, then they proceed to use steam achievements though.

No need to worry people, i have solved your problems!

Hoping they just give Photon Man to everyone someday soon. Not only due to the weirdness of having to have/play AoE1:DE to get it, but also because of the Xbox Store/Steam thing.

And a lot of people have purchased every AoE iteration, spinoff, and expansion pack over the years… supporting AoE financially every step of the way… and just because someone maybe didn’t happen to buy the one new release of AoE1:DE, they’re not able to get an AoE2:DE cheat code? Seems odd. I swear I’ve purchased AoE2 about 4 or 5 times now over the years (CD ROM x 2, Conq’s Expansion, Forgotten Empires, HD) and every expansion pack that came out, plus every iteration of AoE1 and its expansion pack(s), plus, AoM, AoE Online, etc. And that’s just me. So many people have done the same and just because they don’t own AoE1:DE, no Photon Man :frowning:

Will be weird playing with friends and I’ll be the only one forever who can make Photon Man. It’s such a cool cheat; much funner than the car one of yesteryear.

Oh, PS: Don’t get me wrong. I’m a big proponent of having cool cheats unlocked if you succeed with AoE event challenges, and advocated it in the past. I far prefer them over profile icons that don’t do much for me. But I do wonder what the best way is to make cheat codes available to everyone at a certain point… as that would be ideal, so friends can enjoy them together. Maybe make them available to all after 2 weeks or a month of event-related exclusivity? Maybe shudder/cringe make them available to purchase for $0.50 or $0.99? What is the best reasonable way to make it feel like a nice reward for effort, but available to everyone at some point?

2 Likes

Hey Guys, I have a little Question about the Achievment. Would I get the 21st Century Achievment, If I bought me the De of AoE 1 while the anniversary Event is running ?
Thanks for helping your Arizona

I purchased aoe2 de on steam. signed into my xbl account. one of the challenges is for popping the 21st century man achievement on aoe1 DE. I purchased that on the Microsoft store under the same account. I have popped that achievement. But challenge still didnt register? Any help?

Perhaps it’s required having both on Steam or both on Microsoft Store. Or perhaps it’s a bug.

Hey are they gonna do anything about this achievement this is really really unprofessional and not very well tested out for kinks. I hope they end up giving the photon man to everyone on age of empires 2 DE… this makes microsoft games look even worse

I have both of these game at Windows Store version, but i cant get award too.

I guess MS must do crunch mode to fix it

I have the same problem. Bought both on Windows Store.
This is very annoying… :disappointed:

Same problem. I’ve unlocked the archievement on AoE 1 Definitive Edition (Microsoft Store), but it’s not unlocked on Aoe 2 DE (Steam), although I connected my Xbox account with Aoe 2 DE.

There’s no event ongoing right now, you can’t unlock it now for.

Wow. I thought this event is playable at any time. So there is no way to unlock the Photon man cheat?

I guess during next event. Which might be soon since they’ve already had 3 or 4 on DE so far.

Edit: EASTER EVENT! (maybe?)

The Spring Event ended last week which also provided an opportunity to unlock the photon man cheat. I imagine there will be more opportunities in the future.

Since this event has passed, I’m going to archive this topic.