AoE 2 DE crashes when a multiplayermatch starts

Since a few days, I have issues with crashes of Age of Empires 2 DE. The crashes Always occur after a game is found, the 1 minute preptime expires, the game goes into the loadingscreen where sparks fly from the left to the right AAAND… the game closes without an error message. I have played the game for 120 Hours with only few issues, then it started crashing occationally, now it crashes nearly every time.

My hard- and software should be fine, but regardless:
-AMD Ryzen 5 2600 6x3400MHz
-Readon RX 580
-Windows 10

The following things i tried as suggestions from the AoE Website without a solution to the Problem:
-updated grafic drivers
-skaled VRAM way over needed Minimum(around 15GB now)
-used Steam to check for faults in the Programm(none found)
-reinstalled AoE
-did a Microsoft x64 redistributable update
-lowered the graficlevel to medium
-deactivated all mods

I have no more ideas on how to fix the error, nor if its produced by the game or Windows 10 and I hope I came to the Right place to ask for help/suggestions.

thanks for your time.

The last patch fixed it for me.