AoE 2 DE Disconnects me

Everytime I start a new game with my friends I get disconnected after 3-5 minutes.

It Happens before i can even go to feudal age.

Unfortunately i dont have a screenshot. But it would just say "You have been disconnected from the game, check your internet connection(which I did, its stable)

Can anyone help? Anyone got the same problem?


I can’t help you but I got the same problem. My game disconnects after 4:40-4:50 Minutes and I can’t reconnect. Even need to restart the Game to connect to online Service.

Hope you will get Help!

1 Like

same to you.

but i have no hope as of yet. gonna try again tho

fwiw here the screenshot from just now as it happened after 26min(ingame time)


Same with me… Keep getting disconnected after around 5 minutes

I have the same problem, when playing with my friends it disconnect me almost every match, the same error you posted. The only difference is that occurs more when close to 1 hour of match (00:45hrs, 01:20hrs, 2:10hrs). This is very sad, because day after day I experience the same error and can’t play with my friends (who doesn’t get the error). I already restart my internet modem and formatted my PC but no deal :frowning:
I wonder if it doesn’t generate a error/log so we can get more information about the problem?

this is critical failure, why this is not adressed yet!? imposible to play…

1 Like

Seriously, I thought it would be fixed in the “big” patch 34055, but in my first match after the update i got disconected. How can a company release a game with such a huge flaw? It shows a lot of incompetence

pense que estaba solo en este problema, parace que MBL tambien lo tiene