Aoe 2 de wont launch

Here are the last 2 of today.2020.01.27-04.08.40.txt (4.8 KB) 2020.01.27-04.09.29.txt (7.4 KB)

Thanks!! Reset helped for me too now to at least be able to start it again but as i already reinstalled it might be ongoing after reboot.

I have the exactly the same issue. The workaround from @VeecHevo does help. Thank you for that.

Is there a plan to fix this bug? It is quite annoying to reset the app every time I want to start it.

On Steam, I find that I often have to ALT+TAB over to the game after it launches, as my view just stays on the my Steam library screen for some reason; and even then, I often have to do ALT+TAB and click taskbar icon of the game to get it to go over to the game, sometimes multiple times.

Granted, I get a little impatient while it’s launching as the little AoE2:DE pop-up splash screen sometimes seems to stay too long or it goes away and then an abnormally long pause before actual game launch, so I click my mouse in Steam wondering if it worked, etc… and that may be throwing things off. (Sorry, I don’t know the exact process of my steps or what I see (and it varies)… I just know that I often have to ALT+TAB/mouse-click random wizardry to get to the game.)

Not sure if the Windows Store has a similar issue, but you might try to ALT+TAB after you think it should have launched, in case it actually has launched and you’re just not seeing the game because focus remains on your Store or Desktop?

UPDATE: Even when I launch the game from Steam and then don’t do anything (leave the mouse alone), the game launches, but I often have to ALT+TAB to it. It launches in the background rather than take over the foreground.

@Darkness01101 This was my first assumption, too but it is not the case.
The Spash Screen is visible for about 2 seconds but then it is gone. In the Task-Manager I clearly see that the process of AOE2, that just spawned, dies when the Splash-Screen disappears.
The logs confirm too, that the game crashed:

Initializing Localization Manager
Exception type 0xc0000005 occurred at 00007ff68a4b9a1f
Writing out log
1 Like

I’m quite sure that this is a bug. Is it possible to move this Thread to the category Bug?
I prefilled the template for a Bug reporting:

Game Version:

  • Build Basegame: 101.101.34793.0
  • Build DLC Grafics: 101.101.34055.0


After installing and activating the Enhanced Graphics Pack on a System with the Windows Display Language Deutsch (Deutschland), the game no longer starts.
The splash screen appears for about 1-2 seconds, but then disappears. At the same time, the process of the game also stops.
I have three log files:

You will find the error message in the 3rd log.

Initializing UI System
Initializing Additional Options
Initializing Localization Manager
Exception type 0xc0000005 occurred at 00007ff68a4b9a1f
Writing out log

Reproduction Steps:

  1. Change Windows Display Language to Deutsch (Deutschland).
  2. Install the current Version of the Enhanced Graphics Pack from the Microsoft Store
  3. Start the game
  4. Make sure the Option to enable this DLC is set
  5. Stop the Game
  6. Start the game
  7. Game does not start any more

Workaround new:

Change the Windows Display Language:

  1. Search for “lang” and open Language Settings (in German “Spracheinstellungen”)
  2. Change the Windows-Displaylanguage (Windows-Anzeigesprache) to English (United States)
  3. Log off and on again
  4. Start the Game

Workaround old:

  1. Find the App in the Start Menu and right-click it
  2. Select App-Settings
  3. Reset the app (Repair is not sufficient)
  4. Install the Enhanced Graphics Pack again from the Microsoft Store (At least it is not downloaded again)

In Order not to always reinstall the DLC you can do this:

  1. Start the game
  2. Go to Options->Graphics and enable the DLC
  3. Play
  4. After playing disable the DLC in the Options
  5. Stop the Game


Windows Store

Windows 10:

  • Version 1909
  • Build 18363.628


  • Processor: Intel i9-9900KS
  • Grafics: NVIDIA GeForce RTX 2080 Ti
  • Mainboard: MSI Z390 Godlike
  • Memory: Corsair Vengeance LPX 64GB (4x16GB) DDR4 3200 MHz
  • Harddrive: 3x 1000GB Samsung 970 Evo Plus M.2 NVMe as RAID 5 using Intel Rapid-Storage with Stripe Size 16KB


I saw complaints of users who have the same issue in the German page of the Enhanced Graphics Pack in Microsoft Store.

1 Like

You have an extreme fast configuration but I would like to recommend you to change your current RAID-5 to a RAID-0 with a stripe size of at least 64 KB. For games with large packed files a stripe size of 256 KB would be best. Recommended is to follow the suggestion while creating the RAID set. Only if you would use your NVMe storage for direct database access with extreme small record sizes or a lot of small text files you could benefit from smaller stripe size.

RAID 0 is not a good idea. I had 2 failed SSD in the past 3 years, so I can only use RAID 1 - 5 - 10. 1 does not make sense of course, when I want to have performance and RAID 10 is not technically possible (only 3 Slots for M.2 SSDs).
The thing with the Stripe-Size is, that the Intel Rapid-Storage is not a real Hardware-RAID controller, it is technically a Software-RAID (aka Fake-RAID | like the /dev/mdX devices in Linux) and therefore quite CPU heavy, especially when you have bigger stripe sizes.
I did run some performance benchmarks with different block sizes and even the bigger blocks (128MB) were faster on this 16KB Stripe Size.
But nevertheless the stripe size shouldn’t be the issue for this problem.

True, but it could be very well the problem in your case. RAID-5 is not meant for system disks or as fast tier storage.

I just tested it with my notebook, where I have a conventional SSD without a RAID configuration and have the exact issue here, too.

1 Like

You are totally correct. I just realized that I have never exited the game while having EGP enabled, so your experience for sure is a bug. Thanks for your submission.

@anon63664082 Could you help out here and move his bug report into a new thread.

You are not alone, I have the same problem

i just disabled my anti virus and it worked.

I’m using the Windows Defender and run also into Exception type 0xc0000005 occurred at 00007ff7dcba9a1f.

Would be nice to get this solved after weeks…

1 Like

I still have this issue after disabling the Windows Defender.

Me too. Really sad nobody seems to care about that bug. Who needs a correct kill count when even the game is not starting anymore?

1 Like

Hi everyone! I’m glad to see that a few of you have found work arounds to the issues you’ve run into.

For those of your still having trouble it would be very helpful to know which of the steps in the help article below you have already tried.

It would also be extremely helpful to know if the workaround Pihaar1995 posted also works for you.

:hammer_and_wrench: Ensure that your computer meets the minimum requirements to play the game.
-> OK

:hammer_and_wrench: Update your display drivers.
-> Up to date

:hammer_and_wrench: Check your antivirus settings.
-> Using only Windows Defender, still the same issue after disabling it

:hammer_and_wrench: Manually update Microsoft Visual C++ Redistributables and restart your machine.
-> Did not help

:hammer_and_wrench: MICROSOFT STORE: Run the Windows 10 Store App Troubleshooter.
-> Did not help

:hammer_and_wrench: Disconnect additional monitors.
-> Did not help

:hammer_and_wrench: Uninstall and reinstall Age of Empires II: Definitive Edition .
-> This is the only temporary solution, but after the second launch the issue is back again

:hammer_and_wrench: Move the app to a different drive.
-> Tested this on a different Computer but same issue. On my primary PC I currently have only one drive but still more than 1TB left.

1 Like

All tried, nothing works. Really frustrating.

@ADragon8602 Could you or someone from your team reproduce this issue?