AOE DE crashes

#1

Bought this game and cannot play it. It crashes and tells me that a program or process running on my PC is causing a conflict. Cannot figure out what is causing it. I have uninstalled the game twice with no luck. Can someone help me please. I’ve bought and paid for something I cannot play. Help or refund would be greatly appreciated.

#2

Maybe I can help you.
Could you tell me which antivirus application is installed on your computer?

1 Like
#3

Trend Micro internet security

#4

i have a problem with launching this game, the first time i launched it, it ran fine and then couple days later it start to crash on loading screen, i tried to seek for the problem and open the event logs on window and found the DCOM server error, i fixed but still doesnt work. I tried to contact window support for like 10 times, they still cant fix it, they transfer me to xbox technician, reinstall windows, redownload the game, tried to install it on different drivers still dont work, reset my computer still dont work. And i dont know what to do, so im trying to seek out to the developers of this game see if they can help me with this problem.

#5

You can find more information here, for more information you need a Trend Micro account.

I would suggest to check folder and process exclusions or disable Trend AV while you play. Other option is to remove Trend Micro and rely on the built-in Windows Defender.

In order to exclude you need to know the installation folder and probably need to launch Trend Micro as administrator (right click and run as administrator) to be able to add the location or AoEDE.exe executable file (process).

To get the install location of your current AOE DE version launch PowerShell and type:
dir $(Get-AppxPackage *MSDallas*).InstallLocation

#6

It sounds like MS support has been busy with you already.

What is the current state and last thing been done?
If you reset your computer you will need to update a lot again.

Could you post the current event log error after starting the game?

#7

the newest error ive seen right now is this.
the latest thing was done is fixing that DCOM server issues and reinstalling windows 10 ,still didn’t work. MS support said that their best technician still cant fix the problem and they say that maybe only this game devs can figure out the solution.

#8

DCOM 10016 errors are common on Windows 10. I do experience some of these too but I am able to play the game, so they are not always related to AOE DE.

Could you tell me your computer brand, type (laptop or desktop) and model code so I can lookup the specifications?

#9

My laptop is HP Omen 15 2018. And this is my laptop specs:

Operating System: Windows 10 Home 64-bit (10.0, Build 17763) (17763.rs5_release.180914-1434)
Language: English (Regional Setting: English)
System Manufacturer: HP
System Model: OMEN by HP Laptop 15-dc0xxx
BIOS: F.08 (type: UEFI)
Processor: Intel® Core™ i7-8750H CPU @ 2.20GHz (12 CPUs), ~2.2GHz
Memory: 12288MB RAM
Card name: NVIDIA GeForce GTX 1060

#10

The PC specs should be ok… about the eventvwr logs, look after something with ‘MS Dallas’, it’s the codename of AoE DE. Look in the ‘Store’ folder section. (the other folder, in Microsoft/Windows)

#11

You should also check for latest drivers, BIOS and firmware here.
https://support.hp.com/us-en/drivers/selfservice/omen-by-hp-15-dc0000-laptop-pc/20329817

Did you try adding another local administrator account and run it there, or do you sign in on your HP using just your Microsoft Account as user sign in?

#12

Yes. I already tried to sign in as local administrator account and also MS account

#13

I noticed HP recently released BIOS update and there’s also firmware for your Toshiba SSD. Another thing is that they list different driver sets for Windows build 1709/1803 and 1809.

Is everything up to date according to the HP driver page?

Did you find events regarding MSDallas in the Windows event log viewer like @Danicela suggested?

#14

I did update my BIOS and my SSD drivers but still the game doesn’t work.
And yes, everything is uptodate according to the HP driver page.

I went to the event logs again after the game crashed, I didn’t find any logs that says MSDallas.

#15

Did you look in Store folder, not the Application / System ones you find easily ?

#16

Could you launch PowerShell and type the following command:
copy $env:LOCALAPPDATA\Packages\Microsoft.MSDallas_8wekyb3d8bbwe\LocalState\StartupLog.txt $env:USERPROFILE\Desktop

This will copy the AOE DE log file StartupLog.txt to your desktop. Could you post that here please?

#17

This is what I got from running the command in PowerShell.

I did find the Store folder but I cannot access it

#18

You need to right click PowerShell and choose run as administrator. Sorry, I forgot to mention that one.

Could you also type the following command:
$(Get-AppxPackage *MSDallas*).InstallLocation

#19

I did run the PowerShell as administrator and still, it gave me the same result.

#20

Please try again with this line, I forgot to add double quotes. :slight_smile:
copy "$env:LOCALAPPDATA\Packages\$($(Get-AppxPackage *MSDallas*).PackageFamilyName)\LocalState\StartupLog.txt" "$env:USERPROFILE\Desktop"

Still, it doesn’t look like the application local storage folder exists. I don’t know if it’s not created on first start because of the error you are experiencing at the moment. It’s hard to say without any logs.

Could you post back the output of this command too (also with PowerShell launched as administrator)?
Get-AppxPackage -AllUsers *MSDallas* | Select *