AOE DE crashes

For the first command, I still got the same error.

It looks like you are using your laptop with a local administrator account only.

Are you signed in automatically on the Microsoft Store?

If not, please sign and run the game from there by pressing the launch game button after signing in to the Store.

If this still fails to start or generate please add your Microsoft account as secondary user and sign in using that account and try it again.

Could you also type the following in PowerShell and post back results?
dir "$env:LOCALAPPDATA\Packages\*MSDallas*"

Since the beginning, my laptop is always signed in by my MS account

Okay, good to know. We will try one step further now still below your MS account.

Let’s see if you can access that folder by using this command in PowerShell as admin:
dir "$env:LOCALAPPDATA\Packages\$($(Get-AppxPackage *MSDallas*).PackageFamilyName)"

And post back the results again please.

I got this

Now the following, one subfolder further again:
dir "$env:LOCALAPPDATA\Packages\$($(Get-AppxPackage *MSDallas*).PackageFamilyName)\LocalState"

It gave me nothing

You should see the following:
Mode LastWriteTime Length Name
---- ------------- ------ ----
d----- 31-8-2018 15:12 Games
d----- 31-8-2018 15:12 speech
-a---- 30-3-2019 14:56 28003 StartupLog.txt

So there is something wrong with the installation or your profile. Let’s add a local administrator account to check if the game can work there.

Please type the following:
net user /add "admin" "str0ngP@ss1"
net localgroup Administrators /add "admin"

Now sign out and sign in as other user, choose Admin and the password you created.

Follow the out of the box experience and try to start the game again. When launching Windows Apps it will ask you to sign in with a Microsoft account. Choose for this application only otherwise your local account will be migrated to a Microsoft account. This needs to stay a separate administrative local user account.

I would like to recommend to launch Microsoft Store first, sign in with your MS account there (so without migrating and skipping that question) and install all available updates below … and download updates, then if necessary install Age Of Empires from the store and launch it.

You might need this local account again in the future when something is wrong with your MS account sign in. This way you always have fallback and access to your laptop in case of emergency.

I followed all your steps and still I cannot launch the game

First of all I would like to thank you for all your efforts and patience.

At the moment I’m not even sure if it has to do with your Windows 10 installation. But the fact that there is no startup log created at all should be useful information for the developers, who do read this forum too.

What makes the situation more complex is the fact that your brand new HP Omen laptop uses the newest Intel 8th gen CPU and also latest Windows 1809 build. I’m not sure if this UWP game compilation already has been fully adjusted to the latest CPU’s and OS builds too. It was developed before 8th gen was available in the market, so there could be some issues with 8th gen CPU.

Also I don’t know after (re)installation if your HP restore partitions are still there. They become useless after upgrading Windows 10 to a newer build. At this point I would suggest to do a full in-place upgrade of Windows 10 through the new local administrator account using the media creator tool or even a complete clean basic installation by using a USB stick and cleaning all the partitions first.

I can help you further with that if you like.

Is this sure?

For positive contributions and useful troubleshooting. yes of course.

Yes please. I would appreciate it very much.

1 Like

I have a couple of more questions before proceeding.

First. At the time of Windows reinstallation did they;

  1. made you do an in-place upgrade through the following link (Update-assistant):
    https://go.microsoft.com/fwlink/?LinkID=799445
  2. or this one (Media Creation Tool)?
    https://go.microsoft.com/fwlink/?LinkId=691209

Secondly. Although I’m not sure if it’s a requirement (not listed as) and is not installed by default on fresh Windows 10 installations, but most gamers who use Windows 10 to play games will have it installed already as it is an requirement for a lot of older games (and the base code is pretty old).
Is DirectPlay installed?

Please launch PowerShell as administrator again (just use your MS account sign in) and type:
(Get-WindowsOptionalFeature -Online -FeatureName DirectPlay).State

If it says ‘Installed’ you are fine, otherwise paste the following:
Enable-WindowsOptionalFeature -Online -FeatureName DirectPlay

Last (for now) :slight_smile:. Could you open Microsoft Store and click […] in top and Download and updates. Are there any updates queued? And is English Local Experience Language Pack installed from Microsoft Store? I’ve have read something somewhere about that as solution too.

I did check my windows 10 through Media Creation Tool and Update Assistant, they both said my windows 10 is up to date.

After I re-installed my Windows 10, I also manually enabled DirectPlay through Control Panel.

I launched the first command you gave me in PowerShell, and it said “Enabled”.

And lastly, I did open Microsoft Store, and check for updates, everything is up to date. I do have English Local Experience Language Pack installed on both US and UK.

I especially would like to know if you did re-install at that time using Media Creation Tool or the Update Assistant? And if it was a full re-install through USB media or in-place upgrade (from running current version).

At the time that the game did work for a while. How long time ago was that? Were you still running the previous Windows build 1803 at that time? And which AOE build was it if you still know that one of course. Did it have the chat bug?

It was a full re-install through USB media

It has been more than a week since the game last worked

I can’t remember the version number of Windows or the game at that time.

And also, It didn’t have the chat bug

I noticed looking up the specs that you have a small 128 GB SSD. Is the game installed on your SSD or harddisk? How much free space is left on your SSD at the moment?

Actually I do fear that the game is not compatible with Windows build 1809. So if you would choose to reinstall your Windows again I would like to suggest that you get an ISO of the 1803 build and use one. Just empty your USB key and copy all the contents from that ISO to the USB key.