AoE:DE Roll-Over Help Not Showing When Enabled


#61

As it is now, the game (which was initially fine) is completely unplayable. Is there a real-time chat line with which I could review our extensive diagnostic path and results with a technician in hopes of getting this game back to playability?


#62

I’m very curious about the used graphics card in the Surface Pro 6.

You are right of course about that it’s strange that the problem is identical on the two devices, which actually suggests there is something wrong with your MS account. That is why I did the request to test the game with a local account.

In what way is the game completely unplayable at the moment?

Because we did not make drastic or big changes to your system, only fixed minor issues, no harm could possibly be done.

I read some more threads about this. Another advice is to install Windows 10 again as upgrade over the current installation by using the media creator tool. It’s always the last resort, reinstall Windows completely.

For sure you could try to contact your local MS for support.

I’m sorry that all our efforts were for nothing, but it’s the best I could do remotely. Most time it helps enough to solve an issue. And sometimes it doesn’t.


#63

The game is unplayable because one has no way to know what the costs are for the various ‘tools’ or ‘research’ available in a given structure or selection. For example, when I select a temple I see a number of possible research items in the option panel at the lower, left-hand corner, but I have no way to know how expensive they are other than by selecting them while watching the resource bar at the top of the screen. In my mind, that makes the game not playable, since this is critical information necessary for the proper management of one’s resources.

I purchased this Lenovo from Microsoft in the summer of this year. It came with W10 already installed. I doubt that I would consider reinstalling it.

Regarding contact with Microsoft, wouldn’t they just send me to you (as a representative of the game developer)?

By the way, the graphics subsystem in the surface is based on the UHD 620 found in the Core i7-8650U.

What other options for support are there other than “remote”?


#64

First of all. I’m not an official representative of MS. Nobody on this forum is, even the moderators are volunteers as far as I know.

I did want to keep you away from reinstalling, like I said it’s really a last resort. Also we did run DISM to check and repair for errors in your Windows installation source files and afterwards system file scan.

Your Surface 6 Pro is rather new, but the specifications should be enough to run it decently in on Full HD (1920x1080). It may help to lower the screen resolution before playing.

Last question about your Lenovo ideacentre AIO. Is it equipped with AMD or Nvidia dedicated graphics card?
I could not get that from your system details, there are multiple Y910-27ISH signature models.

Other remarkable fact is that the issue happens on two different and rather new generations of Intel CPU (above 5th gen).

Don’t worry they will read this forum. I understand it’s a bummer for you it doesn’t work as expected.

Further you should report your issue in the Windows feedback hub too and hope it gets a lot of upvotes.

Like all these MS programmers are on time sharing these days. :wink:


#65

GPU is Nvidia GeForce GTC1070. Any help?


#66

Nope, supported for sure. Can find enough videos on YouTube with that one. And you also updated all drivers manually, except maybe a few that might have been hidden (I forgot to add a step with that).

Last resort is using the mediacreator to do an in place upgrade of Windows 10 as it is not time consuming like a clean Windows 10 installation. But I understand if you don’t want to do that. No warranty it will work and it is a more intensive step than we have done until now.
https://www.microsoft.com/en-US/software-download/windows10

You might need to call in some technician to help you further on-site.


#67

I think I may have crossed some wires in setting up my “local account”. When I click on the Windows button and select my profile avatar, I see the account I thought would be my local account listed as being signed in! But if that’s the case, then I should also see my Microsoft account listed there, and I do not! And when I go to the feedback hub to enter feedback, it wants me to sign in. Worse, when I click the link to sign in, I see what looks like my Microsoft account with the correct email, but clicking continue hangs the app! Good grief…


#68

This is normal behavior while using a local account. Each and every application will use it’s own sign in capability. Most times last sign in is used and you have the ability to sign out from that application again too. E.g. Xbox hub and Windows store.

While using a MS account or when you connect your MS account to your local account (Windows can ask you this at certain times, Windows converts c.q. migrates your local account to a MS sign in) then that account is used for all applications that require a MS account sign in.

Pfffft. Now explain all of this to your children or average Joe. :wink:


#69

:slight_smile: At least I was able to smile. Especially since I thought I was logged in to my Microsoft account already when I tried to connect! I dunno…


#70

I want to thank you for all your patience and cooperation again.

As I don’t know which technology they use for overlaying those popup’s and it’s even more strange that they only do not appear at the bottom build menu, it’s very hard to tell what it is.

Using the media creator tool to instant upgrade your current Windows 10 installation to a fresh new one (without loosing data and installed applications) could help resolve your problem. But before that.

Another question I have as I notice your SSD is only 128 GB. Did you install AOE DE to your system drive or to the additional harddisk of 1 TB? Or is your Lenovo system configured with redirected profile storage folders to that additional harddisk? And how much free space is left on your SSD?


#71

Interesting question. The game was installed to my C: drive as I wasn’t clear how to set up things so that the D: drive is always used for installs. Anyhow, I have ~25GB free space on C:, and have begun to investigate how to clone that to a larger SSD (this Lenovo model is built to allow easy access to the SSD.


#72

Interesting is my middle name. It’s quite low on free space which could give unexpected problems as well. It’s advised to keep at least double your internal memory as free space.

Forget about cloning.

I would buy a 1 TB Samsung SSD (sweet spot at the moment) and one 2.5" SATA harddisk to USB 3.0 converter (with or without casing) and buy a 8 GB USB stick. Use the media creator tool to create a Windows 10 installation USB stick. If your Lenovo has a product key attached (don’t think so), save that key.

You could also download a tool like ProduKey (from NirSoft, just search with google) to retrieve the BIOS stored Windows key, but in fact you don’t need it at all (anymore) as you can sign in through your MS account on the Lenovo and check on the MS account management page through internet if your Lenovo device has been registered to your account and has been enrolled as owned private device.

Turn off system, take of power. Ground yourself or at least touch ground or iron heating before work. Then just remove the 128 GB SSD and also disconnect the harddisk (only from power and data connector). Install the new Samsung in place of the 128 GB SSD. Turn on system with USB key inserted. Maybe you will have to approve the change of disk system, depends on system BIOS. Afterwards if there is showing a message which says [F12] Boot menu then press that key on the keyboard and choose to boot from the inserted USB stick. If no message appears your computer might be booting to USB stick already and loading the Windows installer. Now just continue all the steps to install Windows and on next reboot remove the USB stick. After install of Windows has been completed create first a local admin account (admin or whatever name you prefer to use for that). First install all available Windows updates, shouldn’t be too much updates anymore. Second use device management to check for missing device drivers. At that point you can use the procedure you have used already before or look up the needed driver on the Lenovo website for your model. I prefer using as less as possible drivers from the manufacturer, so only the ones left I would install from Lenovo. Also regarding Nvidia drivers I keep using Windows original delivered drivers, unless there would be a very good reason not to. Finally add your MS account as secondary user, normal user or administrator does not matter much. You can always use your primary local administrator account to confirm installation and system changes. This way Windows systems works a little bit more like Apple OSX (keep it quiet please :smile:).

Don’t forget to connect your harddisk again, completely wipe it (clear all partitions there, create new basic volume and format as NTFS) and then use it for Windows back-up utility.

And install AOE DE again while keeping your fingers crossed this time.


#73

Great suggestions! I’m investigating them as we speak :smiley:


#74

For what it’s worth, I just checked the game again on my Surface, and it’s definitely showing the same issue as the Lenovo. So, a totally different graphics subsystem, totally different drivers, totally different memory environment, 165 GB free on a 237 GB drive, 8GB RAM. I am really wondering if this issue is system related at all. Can we keep this alive? :thinking:


#75

And one more thing: where do I find the executables for AoE? I don’t see them in Programs Files.


#76

Your surface has only 8 GB system memory of which I could imagine it is not enough to run correctly in 2736x1824 pixels with UHD 620 graphics engine. You should experience zoom issues too. I think you have to lower resolution to at least half of that. Full HD (1920x1080) with all zoom options available requires at least 16 GB of internal memory (or 12 GB, they had changed something about that in the beta).

Did you try it on your Surface with lowering the screen resolution a lot before starting the game? You did try the trick with the local user account creation on the Surface too?

It’s getting a rather long thread this way. You can better p.m. me further. If we get this one solved, we can post the results. I fear it’s a hard one though. MS being of no help in solving issues like this is a bad sign already.


#77

I will PM you for system related issues, but keep this in the related thread, I tried setting the surface resolution to both 2048 x 1536 as well as 1920 x 1440, and neither of those resulted in the appearance of the help tooltips.


#78

Please try lowering to down further to 1600 something. Don’t do this in AOE DE, but through display settings before starting the game. Running lower resolutions in windowed mode will not solve this problem for sure. Just to be sure, maybe you tried it the wrong way.


#79

I used the Windows cPanel Display settings to drop down to 1200x800. Then I restarted the Surface system. I still get no tooltips.


#80

During the beta and in the beginning I can remember more users of Surfaces having this probleem too. It might be these problems never got resolved. The best thing you can do is repeat all previous troubleshooting steps like manually check for device driver updates, the dism check.

BTW. The AOE DE program files reside in the C:\Program Files\WindowsApps folder. They can only be accessed though elevated explorer or PowerShell session (run as administrator). It got no use to do anything there though, it’s fully managed by Windows Store UWP platform.

Let’s say they have still some issues there regarding all these missing popups with certain configurations. Probably the Direct3D11LibRelease_UWP.dll is in need of debugging and certain fixes. I think they should contact you for debugging this issue personally.

What use it got else to sell a game that doesn’t run at all on your own manufactured and Windows 10 pre-installed devices that support 4K like resolutions?

Or to sell a game that doesn’t run correctly on a modern AIO game machine?

Things I would worry myself a lot about if I were AOE DE’s projectleader.