AoE II HD Fails to reach the main menu


#1

Hello, I (or more accurately my father) have had this issue for well over a year at this point.

Here’s what happens: After launching the game (through Steam), the game will briefly show the microsoft logo video and immediately closes, providing no error message. It does generate a crash log which I will gladly provide if someone tells me what the process is.

Here’s what we have tried:

  • Renaming the game application to Launcher
  • Every setting in compatibility mode (for both the launcher and the main application)
  • SKIPINTRO
  • Reinstalling
  • Updating Video Drivers
  • Running the application and/or the launcher as administrator

Until I can provide the full crash log, here’s the relevant part for the crash (I had to open it in visual studio):
“the thread tried to read from or write to a virtual address for which it does not have access age of empires”

Any assistance would be greatly appreciated.


#2

A few first questions.
Did it ever work on his computer before?
And what Windows OS version is used?


#3

No, the original worked but that’s likely irrelevant.
He is running Windows 10.


#4

You still see the logo video even after doing the launcher rename or SKIPINTRO? That’s very weird, I don’t see why that should happen.
The error message you get sound like there’s a problem with permissions. If none of the other solutions help, you can try going to the install folder of Age2HD, right-click and select properties -> security and there give the user account full access to the folder.


#5

This error is very difficult to solve as it can have different causes. Just search on it with Google and you will find multiple topics, also at Steam community.

So it could be an folder access permissions error, but it also could be related to .Net Framework errors.

You tried to launch as administrator and rename launcher. Did you also try to launch the Steam client application as administrator and then install and run the game?

If the original was installed on this machine then installing the Steam version before removing the original version could have messed up things in the registry, also folder locations differ between original and Steam version. Could explain what @Jineapple noted with skipintro thing.

Further info is needed. Please check for AOE II HD logs and all applicable events in the application log of the Windows eventviewer.