AOE IV 8.1.185.0 Hard Crash Bugsplat Error

Will Relic never address these issues? First it was random nowadays it happens daily regardless of the hardware or the settings.

Hi guys, I am using the newest version + DLC and also got basically the same error. I crashed at least half of the times for the last 50 ranked games. I tried everything on Reddit and Youtube (like at least 20 fixes including re-install of Win11, clean boot, verifying integrity files, re-installing AOE4, re-installing and updating graphic drivers, admin rights, starting from RelicCardinal etc.) I also contacted support.

Here is the error message happening some minutes ago: A crash report from application release_10_1_0_RTM_x64 has been successfully logged to www.BugSplat.com as worldsedge_cardinal-2094454.

It even crashes when I just have AOE4 in the background in the lobby after a while.

Cheers!

I have the crashes although I am playing through Steam.

Hey guys ! I finally found the solution… I have a Ryzen 5800X and 7900XTX, Win 11 playing on steam. Incorrect function randomly, at the beginning of the game, at the middle, and sometimes not. I spent more than 15-20h to search in drivers, bios, windows errors etc… I finally found it, you can mp me in order to send me yours specs and talk on discord. A contribution is needed to compensate all the time spent and the efforts. See you guys !

Did anyone of you guys check your CPU/GPU temperatures and/or Power Supply? I guess AOE4 is pushing to the limit.

I have a 4090 and a 5950X
Temps are 40/50C while using and ~30/40 while idle.
This happens randomly, sometimes a lot of times in a day, and sometimes it won’t happen in a week.

Lol go scam people to another place lambucio

Thanks bro, maybe I am that desperate but I love the game. Therefore I bought a new cooler for my CPU and new power supply. I will report if the problem persists

I wish u luck but this is happening to me in different computers old or new, AMD or Intel, Windows 10 or 11, 3080, 3090, 4070, 4090, etc. This is a software issue. This will never happen if I open the game and leave it open for days idling, only while or after playing a match. Maybe it’s related to a specific Civ or Map? We’ll never know… Relic error logging is useless. Closing the app and opening it again after each match helps a lot.

That is weird my friend because it crashes on me also in the lobby or campaign. Does not really matter. But yes I agree that other games work completely fine. I just noticed that AOE4 in general requires a lot of CPU/GPU power and goes crazy with my fans. It is very demanding and heavy on the PC.

Probably we are facing different issues then.
Last crash was 20 min ago.


Plenty of free resources. Device can’t even get to 60’s temp. thanks to my liquid cooling setup.
Just “incorrect function” and the window closed.