AoE IV on Bootcamped 2019 MacBook Pro

Hello - I’ve downloaded AoE IV from Steam on Bootcamp for my MacBook Pro16 (2019). When I try to launch I get the below error
Error Message|690x102

The game then gets to the loading screen, but always crashes - no screen of death, program just shuts out.

I have downloaded the AMD Radeon Pro settings app, updated the driver software (have done the same for my Intel processor) and still getting the same error. Attaching a few screenshots below.

Additionally, I have: deleted bootcamp partition, reinstalled entire Windows 10 OS, redownloaded game, tried file as admin, turning off all firewalls, etc.

I’m really hoping to play this game and re-live great childhood memories of AoE I, II, III. Thank you so much for any advice you have here!
System info below:
Version: 1554. (iBridge: 18.16.14759.0.1,0)
Date: 6/22/2021
Manufacturer: Apple Inc.
Model: Mac-E1008331FDC96864
Version: MacBookPro16,1
Edition: Microsoft Windows 10 Home (64-bit)
Version (Build): 1909 (10.0.18363)

PROCESSOR: Intel® Core™ i7-9750H CPU @ 2.60GHz
GRAPHICS: AMD Radeon Pro 5300M

Graphics Card Manufacturer - Powered by AMD
Graphics Chipset - AMD Radeon Pro 5300M
Device ID - 7340
Vendor ID - 1002
SubSystem ID - 0210
SubSystem Vendor ID - 106B
Revision ID - 43
Bus Type - PCI Express 4.0
Current Bus Settings - PCI Express 3.0 x8
BIOS Version -
BIOS Part Number - 113-D32207P1-019
BIOS Date - 2019/10/10 14:25
Memory Size - 4080 MB
Memory Type - GDDR6
Memory Clock - 1472 MHz
Core Clock - 1250 MHz
Total Memory Bandwidth - 188 GByte/s
Memory Bit Rate - 11.78 Gbps
2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/CurrentControlSet/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0000
OpenGL® API Version - 4.6
OpenCL™ API Version - 2.0

Ok - OP following up for posterities sake. For those with a bootcamped mac do this:

Apple Boot Camp Software Graphics Drivers | AMD

Go to this link download the program. Use the Radeon Software program to update drivers. It will update once, but that isn’t enough - make sure that everything is totally up to date. then use this program to launch AoE IV. Works for me now and doesnt crash.

1 Like

I have the similar above configuration, but still not able to run in bootcamp. Been trying for over 2 weeks now. :frowning:
Can some folk share their success story if any with this configuration, especially AMD Radeon Pro 5300M.

just make sure everything up to date.

Actually I failed in the first time.

But the second time, I updated the BootCamp software on the masOS. then I installed windows in standard steps. I wait a while after successfully installed.

I also download to check/update gpu driver.

With all above done, I can run AOE4 on my MacBook Pro