AOE use my second GPU, ignoring my RTX 3050 laptop GPU

Forcing to use NVIDIA GPU through Windows settings is not helping, I’ve tried. Please help

Do it via the Nvidia control panel

Scroll down here

It doesn’t helped. But, I’ve downgraded my AMD GPU memory via BIOS and AOE automatically started to use my NVIDIA GPU. Closed, thank you.

1 Like

what do you mean i downgraded my AMD gpu memory?
I had same issue with my AMD cpu and rtx3060 gpu on my old laptop, game will start on the internal gpu most of the time even when i forced it to start on Nvidia through NCP and windows settings.