AOE2-DE: Problem with multiplayer games - lagging

Me and my friends are experience lagging almost every time we play online.
We can have lagging of about 30-60sec, that’s unplayable. Sometimes it can be even longer. If we pause the game for about a minute or two then it seems like the game can get back to better response times but then after a few minutes it starts to lagg again.
What can be the reasons for this? Are the servers slow or are there to many people using the servers?

My first thought was the internet connections me and my friends have, but then I learned that we all have fast fiber connections. Next thought was that some of us maybe has slow computers but I don’t think that’s the case, well we all have decent computers but not the best out there. We have also tried to change who is hosting the game but that does not help.

That leaves me with the Age of empires servers. Are there some page that I can find the age of empire servers and and see if they are on their hands and knees?

Can someone please help me figure this out?


What game mode, number of resources, and starting age are you using?

1 Like

300 resources, starting age standard and standard

1 Like

I’m having the same issue. Worked fine about 2 weeks ago. We havent chanaged anything and the lag is unplayable. I have found other poeple with the issue all over the internet but no fix as of yet that I can find. Help please… going to have to go back to HD edition.


This was reported as a bug and there’s no fix that I’m aware of. Please add likes/hearts to that thread, and feel free to post in it, to help bring visibility to it.