AoE2DE.exe is crashing in Initializing Localization Manager Access Violation

Game Version:

Build version: 101.101.34793.0
Platform Microsoft Store

Issue:

Cannot start AOE2DE. The app is crashing
Initializing Localization Manager
Exception type 0xc0000005 occurred at 00007ff751269a1f
Writing out log

Reproduction Steps:

  1. Click on Age of Empires 2 DE tile
  2. Game is crashing

To workaround the issue,
Go to Settings app and reset Age of Empires 2 DE
Then go to Microsoft Store and install again Enhanced HD Grpahics add-on
Start Age of Empires 2 DE and play
Close the game

At the next start attempt, game is crashing again.

Feedback Hub link https://aka.ms/AA7ar3u

1 Like

Same issue with new build 101.101.35209.0
Initializing Time System
Initializing Command Line
Constant Logging is OFF
Verbose Logging is OFF
Startup is being logged
Age of Empires II DE start at 2020-02-14T19:13:33.905Z
Build version: 101.101.35209.0

Initializing Additional Options
Initializing Localization Manager
Exception type 0xc0000005 occurred at 00007ff686cb0b3f
Writing out log

1 Like

Exactly the same error here, workaround doesn’t work, do we have any other solution?

I got the same error…
Anyone get a solution?

I think you can download the Display Settings for English (US) and switch to that, then it will be fixed :slight_smile:


here, i found the thread for you :wink: i think you can use these work arounds to fix your problems @Chriat @AbstruseUser97 @Ismwaell

1 Like

I am sorry, but changing the system language is not a fix, its a poor workaround. This is clearly a bug.

I don’t think that he meant it as a permanent fix.
You could also use the “workaround 3” - this is way more handy but you need to remember to disable the enhanced graphics package before quitting the game.

This bug was initially reported last year and it is very annoying.

1 Like

All workarounds are just jokes and demonstrate a huge quality gap! It’s a shame that such localization issue is preventing people to enjoy and play game.
I’ve stopped playing to AOE2DE due to this issue. Because is so annoying to apply these nasty workarounds

Exactly, of course this is a WORKAROUND and not a permanent fix :rofl: :sweat_smile:
you guys are funny @dominaPam @Ismwaell , I tried to help you… but ok, no good deed goes unpunished. Will remember next time to not waste my time :stuck_out_tongue:
I understand it’s an annoying bug but if the rest of the game runs just fine, you’re still lucky. I can’t even start the game due to some other problems I can’t figure out :frowning:

Indeed, the reaction from them is completely childish … :sweat_smile:
There is a workaround that is not as uncomfortable as changing the Windows language every time or reinstalling the game.
Or they can just remove the enhanced graphics package and the game is running without an issue - and the graphics are still good…

As you can see, I was already aware of a workaround before reporting this issue. But in 2 months, there is no progress at all on this issue because: we have workaround so everything is fine… :roll_eyes:

Ahhh that suggestion literally made me laugh… tried everything already, nothing works… I think it’s time for the developers to look into the bug and finally solve it… PLEASE!! Pretty pretty PLEASE!!

Hello everyone! Thank you for the report; as mentioned in the other thread, this issue has been reported to the team so they can work towards a fix:

If you find any additional information or workarounds, please feel free to visit that thread and leave a comment there, since it has the most up-to-date information about the issue.

Thank you for the report! =)