Aoe3de crashed 100% after upgrade to the latest version when game start loading and sync

yesterday i upgrade to the lastest version of aoe3de, and when i joined a host game and all ready, game start loading , then this aoe3de program just crashed suddenly,
and it almost happened 100% again when i do the same

please help solve this problem, any info needed just message me.

Age3Log.txt (15.2 KB)
DxDiag.txt (109.4 KB)

Do you have mods ?
Some UI mods no longer work after this update.


I played one game yesterday and it went out of sync after maybe 15 minutes. I don’t have any mods installed. I had found a game through quick search but after everyone had loaded in it crashed saying one of the players failed to load or something. That has happened before though occasionally

these are the mods i installed

1 Like

Try to disable “Legacy UI Tweaks”.


I have tried many times and the result is that I can’t redeem the explorer in the game, otherwise the game will crash,The game crashes if you pay to redeem the explorer

1 Like

after unsubscribe all mod, problem solved thanks !~