AOE4 AOE2 crashing at startup cause xbox language is Russian

I played Age of Empires 2 on xbox series x consoles with friends for a year and was very happy when Age of Empires 4 came out on consoles.

From the very beginning of the release, the game either crashed or worked.
While the game was not working well, we were playing Age of Empires 2 with friends.
After some update in early September, Age of Empires 2 also started to crash in startup.

The problem: when the console language is set to Russian, both games crash on startup.
When I change the console language to English, both games work fine.

An important point - I do not change the console region.
Console region is Türkiye.
Now I am locally in the country of Moldova.

The same problem is observed with my friends who are physically located in Russia.

Please fix the game so that I can play it in the console language - Russian.

The console has the latest updates installed. The game has been updated to the latest version.

I uploaded a video to YouTube where I run launch in different system languages: https://youtu.be/yIHWTNxxbqk?si=8U9J1jmc-SAC0VXb

The screenshots: