Arrows does not fly straight

Game Version:

  • Build (####)
    101.101.34793.0 4597979
  • Platform (Steam or Microsoft Store)


Every arrows shot by archers or castle or towers the arrows just spin around like thrown axes or swords. It doesn’t impact gameplay but it’s pretty annoying.

I tried to change graphics settings but with no success.

I wasn’t able to find any solution on internet.

I hope you could correct that little issue.

Reproduction Steps:

Sadly no steps here if you need any informations feel free to ask.

1 Like

I saw this happening as well with ranged units some 3 weeks ago. Unsure if it is still happening as I haven’t played recently. :frowning:


Yes there is a kind of randomness and this not happening every times sorry for missing this detail.

Typically yesterday I played 3 scenarios and just un one of them this bug occured.

Yeah i have encountered this problem as well many times but I do not know since when.
For me this bug only shows up in singleplayer wether in campaigns or standard mode, but actually since this bug has occured i have been experiencing laggy movement as well only in single player however.

I see this bug every time arrows are fired and I have since getting the game.

Guys I found the solution!
You just have to turn V-sync on, at least it worked for me!
The buggy arrows are straight now and even the laggy movement has disappeared!


Hilarious. Why does vsync affect the movement of the arrows?

1 Like

Oh you Know it can make the frame rate more stable. I’ll try that thanks all for your answers. The v-sync is actually not activated so it might be a valid solution.

Yeah it actually makes no sense. It is a bug. The developers might have connected something else with v-sync so it affects the gameplay.