Attila/Bleda cut-scene does not execute after killing the Iron Boar (1st Mission)

101.101 Game Version:

  • Build (34793.0)
  • Platform: Steam

During the first mission of the Attila Campaign, I have not been able to execute the cutscene between Bleda and Attila where Attila saves Bleda from the Iron Boar and then proceeds to betray Attila.

Reproduction Steps:

  1. I have tried on all difficulties
  2. Allowed Bleda be the first to attack the Iron Boar and have his HP drop close to death but still does not execute.
  3. I waited several minutes to see if it takes time to do so to no success.
  4. I attacked the Iron Boar first and then allowed Bleda to agro the Boar but still nothing.
  5. Verified Game files restarted and tried once more still nothing.

I game play clip of the bug (If it is a bug but it will not let me load due to new account)

1 Like

I have the same problem.

Thank you for the detailed report! We have a bug written up on this issue and a fix in the works to be included in a future build! Once you see it in the update notes, let us know if Bleda continues to cause trouble after that point.

Thanks again!

1 Like

I just tested it and it now works! Thank you for our help!