Big Time Modify Attribute Bug?! Can you "refresh" your scenario data?

Running into a really weird problem.

  1. I made a trigger to increase attack of Teutonic Knights by 3. I used Modify Attribute, ADD attack in the amount of 3, and Armor class 4. The trigger worked fine, granting +3 attack to Teutonic Knights.

  2. I then changed the Armor class to 19 to test if it still worked, as the Teutonic Knight is a unique unit, and 19 is the armor class of unique units. After changing Armor class to 19, Teutonic Knights no longer got the +3 attack. It didn’t work.

  3. So, I changed Armor class back to 4 as explained in the first step, back to what was working. But now Teutonic Knights don’t get the +3 attack like they did in step 1!

I’m 100% positive my trigger is correct. I started a whole new scenario, made my trigger exactly as explained in 1) and it worked.

I then went back to my scenario, made a trigger exactly like 1) and it didn’t work.

I then deleted every single trigger that had anything to do with Teutonic Knights, restarted Age of Empires 2 DE, remade a new trigger exactly like 1), and it STILL DIDN’T WORK!

It is as though the entire scenario is permanently corrupted when it comes to Teutonic Knight attack. There’s nothing I can do, add, modify, delete to fix this. It’s just permanently corrupted forever.

Has anybody run into anything like this?
Is there a way to somehow “refresh” the data files for my scenario?
Does anybody have ANY ideas?!?!

I will not recreate this scenario from scratch. It’s been 120+ hours to make it. If I can’t fix this, I’m just going to put AOE2 away at this point. I’d be too demoralized to keep at it.

I then deleted the trigger and made an entirely new trigger exaclty

1 Like

I have actually ran into the same problem. I guess what you are doing is scenario creation and not modding, that’s why you don’t know what’s going on.

And yes, this isn’t a bug. You cannot increase something which doesn’t exist in the 1st place.

You cannot modify attacks and armors for units.

A Teutonic Knight has an undefined attack against unique units. Adding 3 to that still means undefined.

On the other hand, it has 0 armor of Unique Units. Hence taking the entire +10 attack bonus from Samurais. If you add 3 to the armor, it becomes 3 armor of unique units, taking +7 damage from Samurais.

Similarly an Eagle Warrior has an undefined armor of Cavalry units. Taking no bonus damage from Genoese Crossbowmen. If you subtract the cavalry armor by 3, it still is undefined and still takes 0 bonus damage from Genoese Crossbowmen.

An Eagle Warrior has +5 (I suppose) attack bonus against cavalry units and hence doing +5 bonus damage to Knights. Giving it +3 against this class means it does +8 against Knights.

To be clear, the modification of attack is working. It’s just not “sticking” for all units.