Blurred graphics

Hello all,
We’re seeing some weird graphics problems on 2 laptops with Intel Graphics HD 620 and 630 embedded GPU. The display is pixelated with some flickering. Every so often (but no regular pattern), the screen looks fine for a fraction of a section. The options screen is fine and we can change options as normal. Ditto loading games, scenarios, etc. Just not the menu or the game itself.
Trying to start a standard game works, the game loads but is unusable and unplayable because of the graphics. We noticed this a couple of weeks ago. Before that AOE2 DE used to run fine (albeit not with a high enough score for multiplayer games but we have another PC we can use for that, 1 player at a time).
The 2 laptops are running Windows 10 Insider fast ring builds with the latest Intel graphics drivers (Insider fast ring builds could absolutely be the cause of the problem so I have reported the problem through the feedback hub too, just in case). I’ve tried different resolution 1080, 1440, 900, etc. the internal display, high resolution external monitors, “low” resolution 1080p monitors, all show the same problem.

Has anyone else seen this happen? Any thoughts on workarounds?

Thank you.

PS: No need to tell me about the risks of running Insider builds… I’ve been doing alpha and beta testing for 30 years… So I know the rules and the risks.

I know you may have already tried this, but did you have the same image distorion in Windowed and Borderless windowed mode or after do a file integrity check in steam in case something broke during update. Also its peculiar that the current Mongol’s UI isnt loaded (the one with the horses coming down the street in the middle. Did you have and mods prior before that might be causing the issues? you could go to User\%UserProfile%\Games\Age of Empires 2 DE%profile Number%\mod-status.json, open this in Notepad and after “Enabled”: change True to false to turn off mods to see if it could be a mod issue

You may not be aware, but it’s a little risky to run Insider builds…

Hahaha, just kidding! :smiley: :slight_smile:

Actually, it’s really strange/coincidental you have this issue. I was just playing “Thief: The Dark Project (Gold)” on Steam a night or two ago and had just edited one of the game’s .cfg (configuration) files to have the game launch in Windowed mode. (I’ve never used Windowed mode on a game before.) After doing so, the game (which was on my primary monitor) looked pixilated like your screenshot while I worked in a different program on my secondary monitor. However, when I ALT+TAB’ed back to the game on my primary monitor and left-clicked to interact with it, it fixed itself pretty quickly and I haven’t seen the issue since. Am pretty sure that was the sequence of events. And prior to that instance, I hadn’t really seen anything look pixilated like that – like an old very low resolution game – in forever.

So, @NightRaven5809 might be onto something with it maybe being related to Windowed mode somehow. Since you and I had a similar issue, I wonder if Windows 10 doesn’t manage ‘windowed mode’ as well as it should? Maybe try running the game ‘not’ in Windowed mode if you are, or vice versa… or play around with the Windowed settings.

I have a regular PC (not laptop), with an nVidia GPU. So our setups aren’t really the same. Just thought I’d mention that.

What are the different builds for, and why do you play them? Does Microsoft ask certain people to help test various builds? I’m an Insider and am not sure why there are different builds; or if we need to be selected to participate in them, or? I only learned about other builds (branches?) from someone’s random post a couple weeks ago.

Thank you @NightRaven5809 and @Darkness01101

Yeah insider builds… they’re good at breaking things sometimes. Let’s not talk about fingerprint sensors :-). They’re effectively beta versions (sometimes it feels like alpha) of the next version(s) of Windows. The Windows release schedule has 2 releases a year: the spring release adds functionality, the autumn release is a stability release - so businesses who want to keep up-to-date will typically deploy the autumn version unless they desperately need functionality in the spring one. The version of Windows distributed to the insider fast ring builds at the moment is the next spring version (so the spring 2021 release). It’s a test bed. Insider fast builds should not be used on primary devices unless you really know what you are doing (and understand the need for very regular backups). They can (and do) break functionality. They get more stable as we get nearer the release dates. The slow ring is less adventurous! I do not work for MS but I have architected + managed large (10s of thousands) desktop/laptop deployments. So knowing what comes next is important to me as is identifying issues early (and hopefully getting them fixed before release).

Back to the topic!

I’ve removed all mods (through the UI and by editing the JSON file), tried all 3 “windowed” modes. Same result. I’ve updated the Intel graphics driver to the latest (tried 3 versions). My laptop monitor is 60Hz QHD. When docked I use a UHD 27" + a 1080p 24". Both are either 59 or 60Hz. I’ve tried both frequencies - no change. I’ve moved the game between monitors, tried different Windows scaling modes. I’ve had big reliability problems with Steam so I have to use the MS Store version. I’ve also tried with and without the enhanced graphics.

The intro looks fine. I’ve tried alt+tab - unfortunately didn’t work. In fact it broke the UI completely! I can open the dialogue (options, mods, load game) with a bit of random clicking and these are fine. I’ve managed to start a standard game against the AI. It sort of worked. The screen was usable but the pixelated version flickered randomly. It’s weird, there’s no obvious pattern to it. It’s most likely a local issue (graphics, OS, game) as otherwise the forum would be full of people whinging but I can’t pinpoint it. It’s frustrating.

I do have access to a gaming laptop with an RTX2070MQ so I’m not without access to the game (almost 20 years of playing atrociously badly!) but it’s a pain to grab the laptop from the kids when I want to play rather than use my own.

1 Like

Ahaaa! Thanks for clarifying and sharing all that info! :slight_smile: As for AoE graphics, I’m afraid I’m out of ideas : ( Sorry the ideas didn’t work, but good luck and hopefully the solution ends up being something simple!

I’m assuming, also, that you only see this graphics issue on Age II:DE, and other games and miscellaneous programs are fine?

So far everything else seems fine but I don’t play much other than AOE.

1 Like