Bug: Chat Command 104 (don't resign) no longer works

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 58259
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.
BUG: Since the latest update 58289, the command 104 in chat, instructing the AI to not resign, no longer works. The AI resigns every game well before they are defeated–often with 10+ castles and tons of troops left. We are making sure to select EVERYONE for the chat before sending the 104 command. This is a giant bummer because after you get your butt kicked for 2 hours by an extreme AI and finally turn the tide, they quit. It’s happened in 100% of games since the 58259 update.

At the very least we’d like this bug fixed ASAP–although really it would make more sense for the AI to not resign by default for each game–or at least have the player be able to set that as an option for all games. As it is, we have to remember to send that command almost always do remember. But again, since the latest build, the command no longer registers.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Play a game with 2+ humans vs 1+ AI on moderate difficutly or higher
  2. Upon starting the game, immediately send chat command 104 to EVERYONE
  3. Start destroying the AI’s town as soon as you can (usually 1+ hour for us) and notice that they resign the game early and no longer follow the 104 chat command and no longer play to the last unit/building.

:arrow_forward: EXPECTED RESULT

Upon sending the 104 chat command to the AI, it is expected the AI will fight to the last unit/building unless the player reverses the command and sends a chat allowing the AI to resign.

4 Likes

Hi @GinningGlue7927 !

Thanks, we are already tracking this issue!

2 Likes

Thank you for letting us know!

1 Like

Please fix this bug soon. This function is very important for me.

5 Likes

I hate to sound dramatic, but this bug is a game breaker for me.

5 Likes

Just adding that this is happening to us too. And agree that it’s a bit of a game breaker. AI is resigning just by you walking into their town with a large army. We were hopeful it would be patched in the small update a few days ago but we’re disappointed to see it had not. It is a game breaker for sure.

3 Likes

Hello devs!

First, thank you for a fantastic game! Second, it’s been a few patches since this bug was reported and it’s still not fixed. Therefore I wanted to post in more detail why it matters so much, hoping that it will help move the bug up your priority list.

The best way I know how to phrase it for us is this:

This one little bug just sucks out a tremendous amount of joy we get from playing this game! The AI is essentially rage quitting the game.

Imagine you’ve been playing monopoly for 3 hours and finally just passed your opponent in money. And your opponent promptly quits.

Imagine you’re playing in a tough, physical, 2 hour basketball game that you’ve been losing the entire time, and you finally scratch and claw your way back to take the lead for the first time all game. And at that moment your opponent promptly quits and takes his ball and goes home.

That’s essentially what the AI is doing.

When my friends and I play the game we make it difficult enough such that it means something if we win—we don’t like to just roll over easy AI. We want to earn it. We want every game to be such that we have a real possibility of losing. That’s our main criteria when we set up a game. Why? Because of the feeling you get from a hard fought victory after a long struggle! It’s rewarding! It’s why we play! We certainly aren’t getting paid to play this game, we play because of the feeling it gives us when after working together and collaborating, we can finally experience victory and its spoils. Which of us can raze the most buildings, have the best kill/death ratio, which one of us finds that last 1 enemy unit on the map first when it looks like the AI should be wiped out, and rushing over to be the one to kill it! The parts of victory like these bring us joy. This bug denies us a large part of that feeling. So for us and the way we play, this literally is a game breaker because it sucks out a big chunk of the the joy of WHY we play.

We might still win the game, but with this bug we can’t savor that victory.

P.S. Should the devs ever see this post, you guys (and girls!) do a GREAT job. We love that you keep updating and working on this game after so much time. THANK YOU for keeping this fantastic game alive and for adding civs, for responding to feedback and keeping this game alive. People tend to complain at a 10:1 ratio than they take the time to praise. So I want to take time to make sure you know how appreciative we are for all the work you do. Even with this bug, this game is still 10/10.

6 Likes

I have this issue too. it used to work but not anymore. not sure when it was introduced.
This means that for practicing build orders against a dull AI i must setup a custom scenario coz their they never resign.

2 Likes

The same thing is happening here. The code always worked up until the last update about a month or so ago. Now it never works. If anything, the enemy resigns if you mildly inconvenience them now. I enjoy building a devastating army to conquer the enemy, but within a few minutes, the king says something like “Zounds! The peasants are revolting, my tarts aren’t tangy and my election was stolen, even though we don’t have any since I am a king, after all. No wonder I lost!”
As others say here, it is so discouraging, it is a game breaker for me as well. Please let me know when it is fixed. Thanks!

1 Like

Excellent post. I wish more were this entertaining and thorough. Great examples!

1 Like

I don’t mean to be a jerk here, but it’s been 2 months and this hasn’t been fixed. It’s still a gamebreaker. We literaly haven’t played a standard game in 2 months due to this bug. Please fix this!

2 Likes

At least against Extreme Ai it works, it only gives up when i get it down to around 10 vils. At least it did the last time i played vs Ai. Do you set the victory mode to Conquest? Because that also helps.

It doesn’t work for us on extreme AI either. We have tried Hard, Hardest and Extreme. In all cases, the AI quits when you run a large army into their town and damage the town moderately–even if the AI has 100+ buildings and 12+ castles left. And even so, 104 “don’t resign” means “don’t resign!”.

In fact I don’t know why the default is not already that the AI won’t resign. Or why you can’t set that in the game settings. It’s a huge deal–to play for hours, get your butt kicked, and finally crawl back and hit the AI back only for the AI to rage quit and take it’s ball and go home before you can even enjoy your victory.

The game now is not about conquest–it’s simply about getting to a power tipping point in the game–at which the AI will just quit.

1 Like

Any updates? This bug is sucking the joy out of this game for us! lol

Hi!

Is this bug present for you in the new PUP?

https://steamcommunity.com/app/813780/discussions/15/3181237058686387772/

(Log in steam)

I don’t mean to be a jerk here but it’s been 2 months and this hasn’t been fixed

damn only 2 months? some of the bugs we’ve reported lasted into half a year to a year or more 11

well hope they fix this soon

I feel like developers usually only get feedback when people are mad! I don’t want to be that guy. These devs have done an amazing job and work really hard at keeping this a great game! Props and thanks to them all!

This particular bug struck me as odd that it wasn’t fixed yet because I think (I’m not in the code) it would be easy to fix and also because it’s such a game breaker.

I have tried with the new PUP, but noticed somebody in the discord channel stating the bug exists for them with the new PUP. Even so I will try it myself and report back.

1 Like

Devs, thank you for fixing this!

2 Likes

just played a game last night and its not working again =(