(bug) hotkey shift to build military buildings


#1

Hi,
I just noticed a bug on the game and I would like to report.

I’ve been messing around with my hotkeys, changing and trying a bunch of stuff. In this case, the problem came up when I was trying to set Building Hotkeys, for when you select the villager, press A and S for blacksmith (default) or S and Q for barracks.

If I set an Economic building to be built by hotkey ‘A’, and another one by hotkey ‘Shift+A’, it works fine. The game understands the difference between ‘A’ and ‘SHIFT+A’. For instance, ‘A’ would be farm, and ‘Shift+A’ could be market.
If I try that with a military building though, it doesn’t work. The game thinks ‘A’ is the same as ‘Shift+A’.

Suppose outpost is ‘A’, and you want to build barracks on ‘SHIFT+A’. You would select a villager, press ‘S’ (default for military building) and then ‘SHIFT+A’. But instead of having a barracks show up, you still get the Outpost.

I had to work around this by setting military buildings on T, G, V, B. So annoying =.=


#2

I tried this and for me this happened the other way around, so I think it’s not specifically the military menu, but rather in some way the interaction between the two build menus that causes this. This is pretty unlikely to be fixed in HD though, so you probably have to design your hotkeys another way.

I’m a bit surprised that you’d want to use SHIFT+… for building hotkeys. This feels clumsy to me, compared to using just a single letter. If your goal with this is to have every building on a separate hotkey, regardless of military/eco, you could just unbind e.g. the “military buildings” hotkey and always use the “eco buildings” hotkey for the menu, regardless which type you want to build.

Alternatively (This is what I personally do, or the default hotkeys for HD as well I believe), you could use both menus and then just use single keys, e.g. having house on A+Q and barracks on S+Q like the default hotkeys do.

Generally for hotkey editing http://aokhotkeys.appspot.com/editor gives you a bit more freedom than the in-game editor so that’s what I’d recommend using.