[Bug] Tech cost does not reset after modified via Editor/Scenario

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 813780

:arrow_forward: ISSUE EXPERIENCED


While using the Editor, when you add a trigger to modify the cost of a tech and then test/run the scenario any changes made to the cost does not reset afterwards. It persist even when you play a standard game. Luckily it doesn’t work in PVP as it boots you out when researching the modified tech but still works in single player. The tech cost will reset when you quit the game and load it up again.

My custom scenario modifies some tech cost. It wouldn’t be a good thing to require the player to restart the software every time after running it due to the game not resetting it like it should. When modifying the cost for creating units they always reset but not the techs, I’m sure something can be worked out.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

There’s a lot of steps, I do have a video link down below.

  1. Create a new scenario
  2. Place a unit onto the map, one for both players each. A king works great as they don’t move.
  3. Place a blacksmith onto the map for player 1
  4. Change the starting age for player 1 to Imperial
  5. Add a new trigger
  6. Make an effect to modify technology cost, pick “Forging” and change the cost to 1 food/ 1 gold
  7. Duplicate for “Iron casting” and “Blast furnace”
  8. Now “test” the scenario
  9. Check the blacksmith the cost for “Blast furnace” should be 1/1
  10. Check the tech tree, the cost for “Forging”, “Iron casting” and “Blast furnace” should all be 1/1
  11. Exit the scenario
  12. Exit the editor
  13. Create a standard game
  14. Set the starting age to Imperial
  15. Start the game
  16. Build a blacksmith and see that “Blast furnace” should still cost 1/1
  17. Check your tech tree to see the same result

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

After running or testing a scenario that modifies the tech costs, all changes should reset to default upon exiting said scenario.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

Here’s a video of me doing the steps.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

That‘s a really interesting bug!