Bug with Italy's walls?

In Age of Empires III: DE(Steam-PC) while playing with Italy, after the update, i experienced this issue.

This issue happened when i tried to build walls with architect
While i tried to build walls early on in the game-few of them-i couldn’t help continuing the wall build. In the moment-that’s the issue i guess- i had 10 wood so it let me build 1 column and 1 of the other type. I had to re-click to walls to let me just make another 2 parts of walls. Repeatedly not letting me construct a series of walls. Before update it was of course possibly and you had just to pay wood whenever you were able to.

1 Like

wait if you were building with an architect shouldnt there be no price for them at all ?

it did not require wood, but it seemed like that. After fix i don’t know if it does exist.

i actually just encountered what i said last night where even though i was using an architect i had no wood and it woluldnt let me build for some reason. i think it mightve bugged out cause i built walls on the other side of the map with vills spending all my wood in the process then tried to use the architects to build the last of the walls connecting to em i think the rapid change between adding them all to the build queue with walls that cost money and walls that dont mustve glitched the system or something. will try to test this later.