Bugged: Wolves and Rain Mastery


I believe the Mongol mastery “Wolves and Rain” is bugged at the moment. If I had to guess, it would involve the new Yam Network rework.

Current game build is 5.0.14681.0 It’s 5/18/2022 as I type this but have tried doing this the last few days.

I have tried both using deer stones, using the silver tree then upgrading Yam Network, and also starting games in age iv, max resources. I’ve definitely created many units, and had the AI be killed by plenty of them for a while, and no scenario I tried got this mastery to trigger when I eventually surrendered.



I’ve also tried to get this to pop but it doesn’t work. I’ve tried using lancers, men at arms and mangudai on 3 separate occasions, killing well over 30 units while my own were buffed by the yam network aura from outposts.

I’ve also had the same problem. Tried archers, infantry, cavalry. Nothing seems to work since the last patch.

On about my 5th game now and have probably killed 1k plus units with mine affected by yam, and no mastery. Please fix this!

Yes is bugged i couldn’t complete this achievement as well, is the only achievement i left and is very frustrating!!! Please fix asap

1 Like

Thank you for reporting all! The team will look into it.