Buildings sometimes take no damage from bombards

Game: Skirmish (English vs HRE AI)
I had two bombards with no upgrades. Both were doing no damage on an enemy university. This bug did not appear with any other building in that game. I later attacked the building with military units only and they were able to normally do damage to the university, so its not like the damage counter for the building was bugged outright. I also changed the distance of my bombards from the building but they were still doing zero damage. (Edit: the bombards themselves were also not bugged since they worked fine against other buildings.)

I created another skirmish game directly in the 4th age hoping the enemy would make a university so that I could try to recreate the bug but the building did take damage in that case so it is not a university specific bug.


Same experienced that during the siege while I was trying to destroy the walls. When I move the bombard to a different location or unpack and place to shoot it deals.

Very strange.

Strange indeed, I specifically tried relocating the bombards but they still dealt no damage. :face_with_raised_eyebrow:

Do you remember whether you attacked the same wall or was it a different one? Because I remember the bombards were able to damage other buildings afterwards (something I should have mentioned in the original post and will edit accordingly).

For the most part, I think I’ve made a bombard every game that reaches the last age, but this error has been rare enough that its not game breaking. However considering how the only purpose a costly unit like a bombard has is to attack buildings and walls (especially in your situation where its for a wall breach), this bug could be quite critical when it hits you at the wrong time.

I’ve experienced this bug, too. Also on a university with bombards, strangely enough.

1 Like

Doesn’t seem to be a bug specific to universities since Subotai experienced it with walls; I also specifically tested it again with a university in another game so at the very least it’s not a universally reproducible bug. :confused:

Hey !

Got the same issue here, only the univ seems to be immune to the gunpowder siege engines, otherwise, it works with trebuchets and all other units !

Thanks all! I’ve logged this so we can look into it. Appreciate the reports!

1 Like