Can you play "A Christmas story - Director's Cut" on DE or AOK HD (2013)?

In 2006, “A Christmas story - Director’s Cut” was designed for AOE2: The Conquerors ( It looks like an excellent scenario.

Unfortunately, even when I follow the installation instructions correctly, it crashes after the opening Story screen. I think that it probably crashes because it was designed for the original AOE2, whereas I am playing it on AOE2:HD (The 2013 Steam Version) using Windows 7.

I see a few options:

1. Play it on a Downgraded version of Steam. When I downgrade my AOE2:HD version to one of the “Beta” versions like 4.3 that you can install by right clicking on AOE2:HD in your Steam menu, then at least the first minute or two of this Scenario works. I take this to mean that for some reason the Scenario works on the earlier releases of AOE2 rather than the later, HD Steam versions. But unfortunately I don’t know how to Downgrade the Steam version to lower than 4.3.

2. Play it with the “Compatibility Patch” Mode. Another player suggested playing it using the AOE2:Conquerors Compatibility Patch, ( I was able to install the AOE2 Compatibility Patch version fine. At least the Compatibility Patch Version works when I run its .EXE file, and it is able to run the Christmas Scenario. Unfortunately, the Compatibility Patch version’s graphics are defective. Namely, the AOE2 main menu appears as a kind of simplistic grainy, shiny blue or purple hue, and in the game, there is a major smattering of red speckles on the green grass and green trees. It is so bad on the ocean tiles that they look neon purple. This is a known problem with running the original AOK on Windows 7.

The original version of AOE1 has a known similar graphics problem when you run it on Windows 7- the ocean had white or yellow shining speckles, and one easy solution for that is to have the Desktop Resolution screen open and running in the “background” of your computer’s programs. I tried running the Desktop Resolution screen in my background when running the Compatibility Patch and it didn’t solve the problem. The 3 other solutions that I found online didn’t work either (eg. Using compatibility mode in the Patch’s .EXE file’s Properties settings; setting the in-game graphics to Medium, creating a .bat file that kills explorer.exe and then runs the game).

3. See if it works on the Definitive Edition. This might not work for the same kind of reason that the Scenario hasn’t worked on AOK HD (2013).

4. Download the original version of AOE2 and forget about playing the Scenario on DE or the 2013 HD Steam verion. I was able to get the Demo version of the original AOE2’s graphics to work fine by running Screen Resolution. Unfortunately, I wasn’t able to find any free download version of the original AOK that works.

I think, that it can’t work on DE, because it uses outdated DAT file. Author would have to update DAT file to current DAT file version of DE.

1 Like

I haven’t used the compatibility patch myself, but you could try installing the UserPatch on top of it:

I think you just need to download the installer, place the setup executable file in the Aoe2 directory where you have the compatibility patch installed, then run the installer. That should fix all of the color issues (and UP 1.5 is the version you’d want to play, anyway. I think the compatibility patch hasn’t been updated to use the latest version).

1 Like

Good idea!
I figured that the Userpatch wouldn’t work because Userpatch is made for the original version, whereas the Compatibility Patch is made for the Steam version to work like the original version.

I installed Userpatch after installing the Compatibility patch, and this didn’t solve the color problem, unfortunately. The game screen is still a mix of blue, purple, and red. I chose Userpatch 1.5’s option to create a new exe file inside the Compatibility Patch folder, and the new exe ends in “1.5.exe”. I also tried running that new EXE in compatibility mode for Windows XP Serv Pack 2 and 256 Colors and ran Screen Resolution in the background of my Desktop, and that didn’t fix the problem either.