Cannot create ESO account

Yesterday I bought Age of Empires 3: Complete Collection on steam. First time launching it, I was asked to fill a product key. After that I tried to create ESO account, but it failed with “bad CD key” error.
I tried deleting registry keys and filling product key again. Also tried reinstalling game again. But no luck.
Please help.

1 Like

Yeah, I have the same problem mate!
I posted a topic on their reddit and someone replied to me saying “Microsoft ran out of the keys. Hopefully will be fixed soon.”

Hopefully it will be fixed!

3 Likes

Could you guys try the following:

Close Steam client application.
Right click on Steam client application and select ‘Run as administrator’.
Launch AOE III (start with first one) and try to create account again.

This only has to be done one time launched as administrator. I just tested this, as I didn’t do this for the Steam version yet, but it worked for me.

Same problem here,
@PCS70 method didn’t work for me.
I went to the steam Support but they redirected me to http://www.ensemblestudios.com/support.aspx, they have a contact support button that leads you to https://support.xbox.com/en-US/contact-us#3:2:2
I had a live chat with someone of the Microsoft support and got 2 email adresses that didnt work and 6 links that also all didnt work or didn’t have usefull information on them. I still can’t create an account and I hope it is the problem @redstar3120 mentioned so it will be fixed soon.

That’s very strange because after account creation I automatically entered the lobby and also could sign in to http://esoaccounts.agecommunity.com/login.aspx using the just created user account. Although I didn’t receive a confirmation e-mail.

Do you use any strange characters in the ESO account name you try to create?

I still get the error [100] bad CD key and I tried making the account with the name Basiq, I also still can’t login on http://esoaccounts.agecommunity.com/login.aspx.

Well, that’s a basic enough account name.

Did you in the past have the original CD version installed on that computer?

My son and I have the same problem, just bought the game and not able to create an account

Yes I did have had the original CD version installed on computer before, is this causing any problems?

The Developers are aware of the issue and are looking into it.

https://gyazo.com/5525250e01df6c18bb9f62cf053331a8

1 Like

Probably the old keys and product id’s are still registered in your computer’s registry. There is a fix for that somewhere to clear them out. Did you remove the old version before installing the Steam version?

I did remove the game before I installed this new one I think, it has been a while since I played AoE III but me and my friends saw that it was for sale so we all bought it on steam. My friends also tried to do the ‘Run as administrator’ thing but it also didnt work for them. (They did not have AoE III installed before)

@BGdawjaw What is the link/name of this discord server?

1 Like

What issue? It does work for me, but I did buy this game long time ago already without creating that ESO online account. Did that today and it worked.

of the [100] bad CD key
this seems to occur from time to time

someone once suggested this, but no clue if it would work for @LukeKraakman

The registry tweak can help for people who had the original AOE III CD version installed. The key with product id is bound to the ESO account which makes it impossible to use your old ESO account with the Steam installation too. This might be another problem that happens a lot. I think I still got a bunch of those CD keys left over here.

That’s why it works for you. Valid keys only ran out yesterday so new purchases since then are affected.

3 Likes

Thanks for clearing that up. I just thought I was so lucky this time. :wink: :smiley: