Cannot disable halberdier from donjons

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 85614
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Not the most crucial bug here, but it’s probably easy to fix for the devs so…

Normally, in the scenario editor, you can disable any unit from being trainable by going into “options” and putting the desired unit in the “disable” list.

The bug is that it does not work for halberdiers from donjons. Even if putting them in the disable list do remove them from the barrack, you can still train them at the donjon.

The bug applies to any civ (sicilian or not) that owns a sicilian donjon.

:arrow_forward: FREQUENCY OF ISSUE

Only happens if you want to disable the spearmen line units, so it’s miscellaneous

:arrow_forward: REPRODUCTION STEPS

Create a scenario with player one starting in post-imp and a donjon, all units disabled from “options”. when you test it, halberdiers still can be created.

:arrow_forward: EXPECTED RESULT

Halberdier should not be trainable from donjon

Hi @TwinRecord31416
Halberdiers from Barracks and Donjons are “different units”, you have to disable them with triggers :slight_smile:

1 Like

@Felizon89 After trying it, it does not work, since the spearmen line units are not “different units” in the Object List Type. The same goes for serjeants.

If you disable from the options rather than from the triggers, serjeants from castle and donjons ARE different units, but not spearmen-line units from barracks and donjons, so there is no solution for spear-line units yet.

Maybe it’s DLC specific but I don’t think so. I’m on patch 85614, I got all DLCs except Return of Rome

Did you do it like on the screenshot? Using ID 1786.

1 Like