Cannot start AOE2DE from steam (tried everything)


I would please need technical support about AoE 2 DE (on steam). I can’t start the game and can’t figure why… When I click the start button on steam the game seems to load but shortly stops after. I tried a lot of solutions posted on forums (like the support topic)/ youtube but this does not seem to work. I please require assistance as I am not able to play. Here is an error log I get everytime I try to start the game and another one I got before the crashes started to happen.
2020.03.24-14.56.47.txt (3.1 KB) Main.txt (3.1 KB)

Additional information: This crash started to occure the 15th of march (this day I installed a grid mod, completed all campaigns, and maybe but not sure downloaded a windows update), I have been able to play since the release until 15/03 with no problem at all. The error log is quite vague: 0xc0000005.

Solutions that I already tried:
-update drivers (intel and nvidia drivers 100% up)
-update windows -disable “antivirus” (I disabled windows defender)
-change display language to English
-reinstall the game (tried 2 time)
-change game language
-check game integrity
-Rename softwaredistribution and catroot2
-tried uninstalling all mod and deleting profiles.

Sorry for this long post but I try to give as much information as I can. I thank you in advance for the time you have to given to me.

Still not working after months

Hi there! I’m sorry to hear that it’s still not starting. It looks like you’ve done some great troubleshooting! There are still a couple more steps we can try near the bottom of this FAQ. Can you try those out and let me know if anything changes?

I hope this helps!

1 Like

Hey, I tried the remaining steps and some other from the official discord still without success… I don’t know if this can help but I have a log before the crash and one when the crash is occuring.

The exception error occurs right after the time system initialisation:

2020.03.15-17.43.55.txt (6.3 KB) 2020.03.15-18.02.34.txt (3.1 KB)

go to the log folder

delete everything of the aoe2 folder (including where it generates log), not the game folder.

Thanks for the quick answer.
However this solution (if I understood it correctly) does not seem to work for me with the folder empty

Someone told me that Age can generates mdmp files that can be useful for troubleshooting. I found one and it seems my 0xc0000005 error is related to memory corruption???

ExceptionAddress: 00007ff7bc4ace05 (AoE2DE_s!web::http::oauth1::experimental::oauth1_config::token+0x00000000003bcd85)
ExceptionCode: c0000005 (Access violation)
ExceptionFlags: 00000000
NumberParameters: 2
Parameter[0]: 0000000000000000
Parameter[1]: 0000000000000000
Attempt to read from address 0000000000000000


READ_ADDRESS: 0000000000000000

ERROR_CODE: (NTSTATUS) 0xc0000005 - L’instruction 0x%p emploie l’adresse m moire 0x%p. L’ tat de la m moire ne peut pas tre %s.


EXCEPTION_PARAMETER1: 0000000000000000

EXCEPTION_PARAMETER2: 0000000000000000

ADDITIONAL_DEBUG_TEXT: Followup set based on attribute [Is_ChosenCrashFollowupThread] from Frame:[0] on thread:[PSEUDO_THREAD]

0000000000000000 0000000000000000 memory_corruption!AoE2DE_s+0x0

SYMBOL_NAME: memory_corruption!AoE2DE_s

STACK_COMMAND: ** Pseudo Context ** ManagedPseudo ** Value: 23897035b90 ** ; kb

FAILURE_BUCKET_ID: MEMORY_CORRUPTION_LARGE_256_c0000005_memory_corruption!AoE2DE_s

IMAGE_NAME: memory_corruption

MODULE_NAME: memory_corruption

OS_VERSION: 10.0.18362.1

BUILDLAB_STR: 19h1_release


OSNAME: Windows 10

FAILURE_ID_HASH: {376e5b79-7562-cce7-4996-3eb26e12eadf}

Followup: MachineOwner

Anyone understanding this witchcraft?

opem cmd with admin privilege, and type this and enter:

DISM.exe /Online /Cleanup-image /Restorehealth

and after finishes, type:

sfc /scannow

which doesn’t check the game but the windows installations that might be corrupted.

Thanks for this new solution I’m trying it:

Restauration done, then scannow says no integrity violation.
I’ll try restart and play (I keep you informed)

[Edit] Did not work but I’d try any solution

Could you check your time zone and sync settings?

Here is my timezone, from France

Last sync time is extreme long time ago although your clock seems to be running fine.
You could enable automatic time zone and press the sync now button.

Could you also share your dxdiag report file?

I actualized it thanks.
Here’s my dxdiag file [EDIT: I removed the link as it is probably not a good idea to share it on the internet). I also have the minidump from age (I don’t know if this can help)