Cannot upload or release any mod on

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 58850
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Cannot update or release mod on the officials website.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Edit the words of the mod
  2. click submit to Upload or release
  3. wait!

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
It will return the website after updated or give you error hint.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

*No document and it turns circle many hours after I click the submit button.

Please try again now and let me know if you’re still running into issues. Thanks!

Hi,I try many many times,so hard to submit on website only can be upload through game.

I’m not seeing any other failed attempts. If it’s still not working for you, let me know which mod and the approximate date/time you tried and I can check our logs.

Hi,dodonotdodo,the mod is 51743 and I want to add some pictures but always failed,please check why it always happens.This events begin since FEB.13th

I see where it failed on the 13th and yesterday, but only a successful one since I fixed the issue yesterday. So unless you try again now and it fails, I don’t think there’s an issue any more.

It is circled now and this is the picture.

30mins past,still circling!


Ok, I was finally able to track it down. It shows that you’re not logged on or that your login has expired. Try logging off the web site (hover over user name in top right, select Log Out from the menu), then log back on. If it still fails, make sure you’re not blocking cookies for

I’ll also log a bug for this as it shouldn’t just get stuck like that in this case, it should prompt you to re-login.

Now i relogged it again and try.

we wait for 10mins and track it.
i find it stuck at the website no error infomation

The official site sucks and how it constantly unlog the player just by going to another page… :unamused:

Try one more time. It looks like it’s just one server having an issue so I restarted it.

I try again and wait the result.
unfortunately it stuck and my mouse cannot slide up and down and cannot be updated,please check the log.

I can easily upload or update in games but cannot use the officials website to do it.
How you explain this?I have find all the way I can do ,and it didn’t have error before feb.13th.I am helpless.@DodoNotDoDo

Looks like the login issue is fixed now. Now that it’s going through I’m seeing an error about the image format. Are one or more of your images something other than a jpg or png?

The game does use a different authentication mechanism and image handling, so it’s possible it could behave differently than the web site.

Thanks to it,the last question is the image format,I make it little change and done.Looking forward to the third DLC and wish you all the best with your work.@DodoNotDoDo

1 Like

Glad it worked, sorry for the extra effort!

1 Like

Hi,I cannot update my mod,can you help me?@DodoNotDoDo

Should work now. Please try again.

I’m seeing new errors with your latest attempts to publish that the zip file is using an unsupported compression method. If you used something outside the game to create the zip file, be sure it’s not using any out of the ordinary settings.

1 Like

I have use this method many many times but sometimes done sometimes failed,I do not know why it could be this situation.

Cannot work well