Can't change Ram hotkey in seige workshop

I use re-mappable hotkeys instead of the grid hotkeys and since the ram was added to the seige workshop, it uses R, which is also the key for bombard cannon. I’ve tried removing the hotkey and changing it to something that isn’t used in the seige workshop, such as M and it just stays on R. I’ve checked that the change saved as if I go back to the hotkey settings, it says M, but the game still uses R, so when I press R, it builds a ram and not a bombard, so I have to click on bombards with the mouse.

Hey @th3lon3ging3r! It seems to work correctly when I remap. Is this happening only with a particular civ?

OK, I just tried it again and it’s using the new hotkey now. Maybe I needed to restart the game. I’m sure I’ve changed other hotkeys before without having to this.

I can’t remember which civ I was using at the time. I just tested with Delhi and French and it was fine.

Thanks anyway!

OK, it seems the problem is with Malians. In the Malian workshop, the ram shortcut is still R.

Nice! Thanks for this. We’ll get this looked at.