Can't complete Delaware challenge

I’ve tried 3 times to complete the Delaware challenge. I’ve always gone to the challenge screen and clicked begin button. It’s supposed to work in single player skirmish correct? I’ve played 1 game in extreme difficulty with handicap and 2 games medium difficulty with no handicap. 1 game in great lakes map and the other 2 in New England map. What is the criteria that it looks for to grant credit?

I think you have to login to your Xbox account.

You can also set difficulty on easy… I think they count the Handicap as cheating

I was logged in to the Xbox account.

One game I tried it with handicap turned off. Still didn’t work.

Did you resign or just click quit? Or did you win the match?

The first 2 times I completed it, it didn’t count as accomplished. Then I logged in in my XBOX live account and it worked. Dunno if it’s related or not. Didn’t had any problem since then.

I won all the matches.

For some reason the next day when I logged in I got credit for the Delaware Challenge. It’s like there’s a delay.

hmm, wouldn’t be the first time there’s a delay like that

or maybe it wasn’t connecting with your XBL account idk