Can't download any mod

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: ######
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


Since last update, I can’t download any mod. The mods that I have already installed still working (except for four specific mods), but I can’t download new mods.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

Always, since last update

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Open the mods section
  2. Try to download some mod

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Well, if it worked, I could download new mods, specially the map-packs for two important tournaments that I’m playing this week (RMS Cup 2, Nomad’s Warriors) and I could practice

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

In the last image we can see some specific mods that I have already installed but they are not working

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

1 Like

Hey @Toms1337

We are already tracking this issue. Despite that perhaps some of the following things might help.
Could you try verifying integrity of game files?
If that does not help You could try to sign out of Xbox live (if you are not signed in, try the opposite) and installing the mods that way. I don’t think its the same issue but it is worth a try.


I tried verifying integrity of games files, but it didn’t worked
Sorry but I don’t know what is Xbox live, I just play on Steam

Hey @Toms1337

In-Game, you can sign in/out of Xbox Live via the button shown in image below:

It was just a guess and likely will not solve it, but worth a try perhaps?

This issue is also known to be happening to users with non-english characters in their windows usernames. If this is the case for you, you could try to make a new windows profile without such characters and try it on that.

1 Like

I changed my windows username but it didn’t worked