Can't install AOE DE Beta

Everytime I try to Install the Beta it says that there is a problem on Microsoft end and tells me to try again later. How can i fix this problem. I have the latest update already installed.

1 Like

Hi @Yondi03, Are you able to install any other apps from the Microsoft Store without an issue? You may need to run WSReset.exe to reset the Microsoft Store app.

Same thing happens to me. I’ve restarted the Microsoft Store several times (using WSReset.exe), changed region to USA, restarted… Nothing seems to work. I see that the guy above is spanish too, could it be a problem with insiders in our region? Hope to get a response soon, I was so hyped to try the game and this kinda blows.

j’ai le meme probleme en france tout est à jour

Hi @RadiatingBlade, Yes i’m able to install other programas and apps. Just installed pinball to test if everything worked. it could be my region, i’m in Colombi.

Exactly the same error. I hope there is a solution soon, mine tells me it is a server error, other apps still function normally… I am from Sweden if that helps in any way.

Well no response, seems like we are not participating in this beta, even if we were told so… Thanks Microsoft Store, looking forward to playing on Steam to avoid all this nonsense :slight_smile:

I was having the same issue… Also I was getting random errors ( 0x800706D9) and windows update would work… If you already ran the wureset.exe script and not working then do or check this:

Here is what I did :

access the Windows Services , follow these steps:

  1. Click Start , type Services .
  2. Right-click Services and click Run as administrator .

Make sure that all three of these services are set to Automatic .

  • Windows Update
  • Storage Service
  • Windows Firewall

To change the status of a service, double-click the Service , change the Startup type to Automatic and click OK to finish. MAKE SURE you hit " START" if the service is NOT running and try again and be sure to Restart your computer for the changes to take effect.

If this helped anyone out there please give me a thumbs up or LIKE :ok_hand:!!!
Thanks!!

Hi,
I can try and help you fix it… i just posted something that may solve your problem.
SEE ABOVE post :point_up::point_up:
Let me know if this works!

Wow, thanks man, I don’t know why but it actually worked! I appreciate it, download is starting now :slight_smile: